summaryrefslogtreecommitdiff
path: root/dev-python/pyrqlite/pyrqlite-2.1.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-02-18 08:10:15 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-02-18 08:10:15 +0000
commitfceeb864f5e0e6155b3f5ed010298e5b7b2f1278 (patch)
treeeae9568ab98ccfbd977dade72fecdd45c670fc9d /dev-python/pyrqlite/pyrqlite-2.1.1-r1.ebuild
parent517343fddd94e620e94be97ae22eca4b57dc7625 (diff)
gentoo auto-resync : 18:02:2023 - 08:10:15
Diffstat (limited to 'dev-python/pyrqlite/pyrqlite-2.1.1-r1.ebuild')
-rw-r--r--dev-python/pyrqlite/pyrqlite-2.1.1-r1.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/dev-python/pyrqlite/pyrqlite-2.1.1-r1.ebuild b/dev-python/pyrqlite/pyrqlite-2.1.1-r1.ebuild
new file mode 100644
index 000000000000..e267aec4f7bc
--- /dev/null
+++ b/dev-python/pyrqlite/pyrqlite-2.1.1-r1.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+inherit distutils-r1
+
+DESCRIPTION="Python client for rqlite"
+HOMEPAGE="https://github.com/rqlite/pyrqlite"
+SRC_URI="https://github.com/rqlite/pyrqlite/archive/v${PV}.tar.gz -> ${P}.tar.gz
+ https://github.com/rqlite/pyrqlite/pull/42.patch -> ${P}-test_cPragmaTableInfo.patch"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+BDEPEND="test? ( >=dev-db/rqlite-6.7.0 )"
+
+PATCHES=( "${DISTDIR}/${P}-test_cPragmaTableInfo.patch" )
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -e "s:^__version__ = .*:__version__ = '${PV}':" -i src/${PN}/constants.py || die
+ distutils-r1_src_prepare
+}