summaryrefslogtreecommitdiff
path: root/dev-python/pyroute2/pyroute2-0.7.12.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-13 05:35:51 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-13 05:35:51 +0000
commit9e166f0fa8bc64fb267aaba88d9a55f8393e15a0 (patch)
tree8e5bf47e5b23c73057fb21ad97f5babca40da0cd /dev-python/pyroute2/pyroute2-0.7.12.ebuild
parentfd3c1be769bb61186a7d433ce694b0059a8f84a5 (diff)
gentoo auto-resync : 13:02:2024 - 05:35:50
Diffstat (limited to 'dev-python/pyroute2/pyroute2-0.7.12.ebuild')
-rw-r--r--dev-python/pyroute2/pyroute2-0.7.12.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/pyroute2/pyroute2-0.7.12.ebuild b/dev-python/pyroute2/pyroute2-0.7.12.ebuild
new file mode 100644
index 000000000000..58c1cf80ba9a
--- /dev/null
+++ b/dev-python/pyroute2/pyroute2-0.7.12.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A pure Python netlink and Linux network configuration library"
+HOMEPAGE="
+ https://github.com/svinota/pyroute2/
+ https://pypi.org/project/pyroute2/
+"
+
+LICENSE="|| ( GPL-2+ Apache-2.0 )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+# tests need root access
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+"