summaryrefslogtreecommitdiff
path: root/dev-python/pyroute2/pyroute2-0.7.10-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-04 23:42:56 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-04 23:42:56 +0000
commit7b43cd44c0c26cd9e0ae1dcd94596667cb119ee6 (patch)
tree9715703a1ec2185bfa303bd2d2b04e560654f72a /dev-python/pyroute2/pyroute2-0.7.10-r1.ebuild
parent27ad6a285576ce16e4c74d806efee77166f0c3c6 (diff)
gentoo auto-resync : 04:02:2024 - 23:42:56
Diffstat (limited to 'dev-python/pyroute2/pyroute2-0.7.10-r1.ebuild')
-rw-r--r--dev-python/pyroute2/pyroute2-0.7.10-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/pyroute2/pyroute2-0.7.10-r1.ebuild b/dev-python/pyroute2/pyroute2-0.7.10-r1.ebuild
new file mode 100644
index 000000000000..5450ffde31c0
--- /dev/null
+++ b/dev-python/pyroute2/pyroute2-0.7.10-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+PYTHON_REQ_USE="sqlite"
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="A pure Python netlink and Linux network configuration library"
+HOMEPAGE="
+ https://github.com/svinota/pyroute2/
+ https://pypi.org/project/pyroute2/
+"
+
+LICENSE="|| ( GPL-2+ Apache-2.0 )"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+# tests need root access
+RESTRICT="test"
+
+BDEPEND="
+ dev-python/setuptools-scm[${PYTHON_USEDEP}]
+"