summaryrefslogtreecommitdiff
path: root/dev-python/pyqtgraph
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-12 08:41:54 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-12 08:41:54 +0100
commit4df3bf9762850b34cd1ead5c80374d1a0fc3362e (patch)
tree3080c5cb7ad17abcb63776a9f21c4947845546a6 /dev-python/pyqtgraph
parent814f4cf860e299a046b649eaee5463427984c09c (diff)
gentoo resync : 12.07.2021
Diffstat (limited to 'dev-python/pyqtgraph')
-rw-r--r--dev-python/pyqtgraph/Manifest2
-rw-r--r--dev-python/pyqtgraph/pyqtgraph-0.12.2.ebuild89
2 files changed, 91 insertions, 0 deletions
diff --git a/dev-python/pyqtgraph/Manifest b/dev-python/pyqtgraph/Manifest
index 840a3ac8c387..997227331ab0 100644
--- a/dev-python/pyqtgraph/Manifest
+++ b/dev-python/pyqtgraph/Manifest
@@ -1,4 +1,6 @@
DIST pyqtgraph-0.12.1.tar.gz 899513 BLAKE2B 17f6dec41039186ceb0afdfbcba64aebf5900d17b890d9a6d1f8a30586a27e3cc61bb1d3a8fb2446f9ee3a66c54095b7c5d37b5c5fb83296b481d8a95a7fdab5 SHA512 b1ed004c7db4ee4f8302a42dd9e8574692b4c353bf512ec7a42d5ebeaab126e9ed5df3a228c631dc77e16a61efce1c918cbd0a8b319649e346e2082215c56d40
+DIST pyqtgraph-0.12.2.tar.gz 1292676 BLAKE2B af5e61bbc7f55cda669825a9742a3f2424638d35e3a10b85b7fc635a5e40b630848bed1e88bc84383cbd3e85de538b1b1fa051d6d761b368209c1d8167f55a2a SHA512 8a7f0e1e78cf147568ee6e393a07f07301632765d1bdb50328fcf1f815dda76f3e89808cef945409dcd9142407f864f205778a76cf804d4cbce544c60bcf5042
DIST pyqtgraph-test-data-8.tar.gz 306068 BLAKE2B f3aa418dfaf2e74950fa880da4b6dfb4ef5dbd46346b78065d885c1f9fc06fc3de86756af17e27035d4cd47d98cc7ce58c036b493837b568086a4ebceb230c78 SHA512 07ef414f2b57e00589f8c18459e88ab16001c7cc3766164cdfcd69faa26cbc90ed64611fd0c5e3b401dc6a3f1a6e9e4ce6a7d9fa96ebcc4360e03fa9fbb856d2
EBUILD pyqtgraph-0.12.1.ebuild 2357 BLAKE2B 813534be9225f64cbd2d9d6539d24092cdb0338a494ef10066628f01ed2bc108a70a6233db56db5e25ccb1a1ca9c34648be4e817c244f3be3dbeb0b86b46a901 SHA512 54207e530efd6dd391e7162bc68942cbf2a4e41885d4f19a16061038f9623145c13d8617e112e66db94e3b2e1d590fa789c37c314895882e88cd9a1e74774a55
+EBUILD pyqtgraph-0.12.2.ebuild 2450 BLAKE2B e867cc19b84e0ddb1057ddd468669202beab38a73135ea4643e4e4a1a9458b35da0e1d9cd660fc61e629928f7749145c6e8cb0d1aee7dc5d08bd803adea2c3b9 SHA512 df1454e4bde7b7a6b693702ec7180a604644a7dec4c48c264d25262dc63137d95f114a08f5d0a03c22eb5840cb3f0007fe0d933d92c102512456cbfb4586e9c7
MISC metadata.xml 750 BLAKE2B 2382ebf2081e2cc83e363f6716a5af4932dc7fc67b19c06af77fc9557e6e4052a882c79f734c4e96a3d1d49e1c9c7c10d3d1d1872cd1b54f86e943c0cbcdbb0c SHA512 1debda41c5945a1b1a55bb93a8220b17c2078216415195d75e5052571c340ac0e1a43d63f77c6818e69b57ca8cbd2d9a753a749c36dd6bcf803418c10e225301
diff --git a/dev-python/pyqtgraph/pyqtgraph-0.12.2.ebuild b/dev-python/pyqtgraph/pyqtgraph-0.12.2.ebuild
new file mode 100644
index 000000000000..523718072f98
--- /dev/null
+++ b/dev-python/pyqtgraph/pyqtgraph-0.12.2.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..9} )
+inherit distutils-r1 multiprocessing
+
+TEST_DATA_TAG=test-data-8
+DESCRIPTION="A pure-python graphics and GUI library built on PyQt and numpy"
+HOMEPAGE="https://www.pyqtgraph.org/ https://pypi.org/project/pyqtgraph/"
+SRC_URI="
+ https://github.com/pyqtgraph/pyqtgraph/archive/${P}.tar.gz
+ test? (
+ https://github.com/pyqtgraph/test-data/archive/${TEST_DATA_TAG}.tar.gz
+ -> ${PN}-${TEST_DATA_TAG}.tar.gz
+ )"
+S=${WORKDIR}/${PN}-${P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples opengl svg"
+
+RDEPEND="
+ >=dev-python/numpy-1.17[${PYTHON_USEDEP}]
+ dev-python/scipy[${PYTHON_USEDEP}]
+ dev-python/PyQt5[gui,widgets,opengl=,svg=,${PYTHON_USEDEP}]
+ opengl? ( dev-python/pyopengl[${PYTHON_USEDEP}] )"
+BDEPEND="
+ test? (
+ dev-python/h5py[${PYTHON_USEDEP}]
+ dev-python/PyQt5[svg,testlib,${PYTHON_USEDEP}]
+ dev-python/pytest-xdist[${PYTHON_USEDEP}]
+ dev-python/pytest-xvfb[${PYTHON_USEDEP}]
+ dev-vcs/git
+ )"
+
+distutils_enable_sphinx doc/source
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ distutils-r1_python_prepare_all
+
+ if use test; then
+ mkdir "${HOME}"/.pyqtgraph || die
+ mv "${WORKDIR}/test-data-${TEST_DATA_TAG}" \
+ "${HOME}"/.pyqtgraph/test-data || die
+ cd "${HOME}"/.pyqtgraph/test-data || die
+ # we need to fake a git repo
+ git config --global user.email "you@example.com"
+ git config --global user.name "Your Name"
+ git init -q || die
+ git commit -q --allow-empty -m "dummy commit" || die
+ git tag "${TEST_DATA_TAG}" || die
+ cd - >/dev/null || die
+ fi
+ if ! use opengl; then
+ rm -r pyqtgraph/opengl || die
+ fi
+}
+
+python_test() {
+ local deselect=(
+ # apparently fragile
+ --deselect tests/test_reload.py::test_reload
+
+ # TODO
+ --deselect tests/graphicsItems/test_ROI.py::test_PolyLineROI
+
+ # pyside2 is normally skipped if not installed but these two
+ # fail if it is installed
+ # TODO: this could be due to USE flags, revisit when pyside2
+ # gains py3.9
+ --deselect
+ 'examples/test_examples.py::testExamples[ DateAxisItem_QtDesigner.py - PySide2 ]'
+ --deselect
+ 'examples/test_examples.py::testExamples[ designerExample.py - PySide2 ]'
+ )
+
+ distutils_install_for_testing
+ epytest "${deselect[@]}" \
+ -n "$(makeopts_jobs "${MAKEOPTS}" "$(get_nproc)")"
+}
+
+python_install_all() {
+ use examples && DOCS+=( examples/ )
+ distutils-r1_python_install_all
+}