summaryrefslogtreecommitdiff
path: root/dev-python/pyqt-distutils
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-16 09:32:48 +0100
commit9ee6d97c2883d42f204a533a8bc1f4562df778fb (patch)
treeb690ddc0ca30f1472887edbb0b8313629bfcbbb2 /dev-python/pyqt-distutils
parentb17a3ef12038de50228bade1f05502c74e135321 (diff)
gentoo resync : 16.09.2020
Diffstat (limited to 'dev-python/pyqt-distutils')
-rw-r--r--dev-python/pyqt-distutils/Manifest4
-rw-r--r--dev-python/pyqt-distutils/pyqt-distutils-0.7.3.ebuild (renamed from dev-python/pyqt-distutils/pyqt-distutils-0.3.0.ebuild)20
2 files changed, 11 insertions, 13 deletions
diff --git a/dev-python/pyqt-distutils/Manifest b/dev-python/pyqt-distutils/Manifest
index 0ce8d70d280d..facb57f02296 100644
--- a/dev-python/pyqt-distutils/Manifest
+++ b/dev-python/pyqt-distutils/Manifest
@@ -1,3 +1,3 @@
-DIST pyqt-distutils-0.3.0.tar.gz 4659 BLAKE2B 2897696881c6ee18558eb24a923b6675588bd38456fc4e9aff6b1780e7c2c31576c4a7427104c0b15238bed1ad52e2f13ab316441adb06fc0ffd9cbe5052ef30 SHA512 052a1fa0e687ac9aba5fc9623c72f8fff9a25f6d19083668e900ad1ff98bdd99c66c0ac45ba5f5f0c09b76a97370ebf4a4fef9fbd266bc0312bb05567c4ae577
-EBUILD pyqt-distutils-0.3.0.ebuild 522 BLAKE2B b1a6c5f57f19b4fa2108c7695c0ba5d2b3e60d028c25db78867c3e02969e58d37e9bbd5afca527d46d9ae279b7b198ac7c13e943c2ee6ab90aa6485e2d478c9f SHA512 f3462f74e13e88a9bfa72fd21c89e6ac9cf43c3baf3e9f19ac180b109ed51b8519303928604055333de7d4f937587041bac4a1ffcdb4684d59113921bc810519
+DIST pyqt-distutils-0.7.3.gh.tar.gz 16628 BLAKE2B 0d9d7f951890c00efd95bf3caef8c8964d02f3097840f84006a8d9523c0ad9b78dbb5f46c4d752945074ba971c92e81e81be0345b7a8c807932e7157ecd00e03 SHA512 450569be205aa0de792c3f2d8c43e26eb6fed1088b241291347ae14d2343b61517bd7547f741bd62bb9e1bfb92077d1ae5c64b871c39d59a67ca82172ac1c598
+EBUILD pyqt-distutils-0.7.3.ebuild 607 BLAKE2B 151fb272e3c929937f6cc887861d9c3447cee52807543c1e20f8eca98de9b43ea0e18a36ba4cc24abe30b3a9de2b92253f91dab5d1969a78fd637f1b6be8578b SHA512 16edcf6a1de7ddaa5f2d7a986e45eb083b62e0ecdb6d075261c5c7b98fbc08dbdd0e1c58e2c3fa8e975d846064a4c74860f79137fadbda584eaf99281efdd3b5
MISC metadata.xml 410 BLAKE2B 3ed7ef5688df2c5f2e4bec3044d79f225b8b8154ccae5bc487a444aabeadeed5af2e8d60392b09fb731103572da91edacc13fe669e89490a7d30fb585ace1d5e SHA512 52c81f7e76feeb110ca5bf49da1c3fbc82c2b4f61c02ba7622312631c4a9618e42df1cba0f62253f039427b21420751f981d0541b7892ff162ac6e27aeee7748
diff --git a/dev-python/pyqt-distutils/pyqt-distutils-0.3.0.ebuild b/dev-python/pyqt-distutils/pyqt-distutils-0.7.3.ebuild
index c83838844b80..ba764f5808df 100644
--- a/dev-python/pyqt-distutils/pyqt-distutils-0.3.0.ebuild
+++ b/dev-python/pyqt-distutils/pyqt-distutils-0.7.3.ebuild
@@ -1,25 +1,23 @@
# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python3_6 )
inherit distutils-r1
+MY_P=${PN/-/_}-${PV}
DESCRIPTION="distutils extension to work with PyQt applications and UI files"
HOMEPAGE="https://github.com/ColinDuquesnoy/pyqt_distutils"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+SRC_URI="https://github.com/ColinDuquesnoy/pyqt_distutils/archive/${PV}.tar.gz -> ${P}.gh.tar.gz"
+S="${WORKDIR}/${MY_P}"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
-"
+RDEPEND="dev-python/docopt[${PYTHON_USEDEP}]"
-RDEPEND="
- ${DEPEND}
- dev-python/docopt[${PYTHON_USEDEP}]
-"
+distutils_enable_tests pytest