summaryrefslogtreecommitdiff
path: root/dev-python/pyqt-distutils
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-09 17:34:58 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-09 17:34:58 +0100
commitbac9556f73da9ac333933778ce81c053bd989a26 (patch)
treeda4df6abc6ad52afd906c19c1e489d4b1331f6b1 /dev-python/pyqt-distutils
parentc83738e70baeab2df370c1c73b13bb8feb99eb11 (diff)
gentoo auto-resync : 09:04:2023 - 17:34:58
Diffstat (limited to 'dev-python/pyqt-distutils')
-rw-r--r--dev-python/pyqt-distutils/Manifest2
-rw-r--r--dev-python/pyqt-distutils/pyqt-distutils-0.7.3-r1.ebuild31
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/pyqt-distutils/Manifest b/dev-python/pyqt-distutils/Manifest
index 4bec5ec364cc..d803a1a8df7b 100644
--- a/dev-python/pyqt-distutils/Manifest
+++ b/dev-python/pyqt-distutils/Manifest
@@ -1,3 +1,5 @@
DIST pyqt-distutils-0.7.3.gh.tar.gz 16628 BLAKE2B 0d9d7f951890c00efd95bf3caef8c8964d02f3097840f84006a8d9523c0ad9b78dbb5f46c4d752945074ba971c92e81e81be0345b7a8c807932e7157ecd00e03 SHA512 450569be205aa0de792c3f2d8c43e26eb6fed1088b241291347ae14d2343b61517bd7547f741bd62bb9e1bfb92077d1ae5c64b871c39d59a67ca82172ac1c598
+DIST pyqt_distutils-0.7.3.gh.tar.gz 16628 BLAKE2B 0d9d7f951890c00efd95bf3caef8c8964d02f3097840f84006a8d9523c0ad9b78dbb5f46c4d752945074ba971c92e81e81be0345b7a8c807932e7157ecd00e03 SHA512 450569be205aa0de792c3f2d8c43e26eb6fed1088b241291347ae14d2343b61517bd7547f741bd62bb9e1bfb92077d1ae5c64b871c39d59a67ca82172ac1c598
+EBUILD pyqt-distutils-0.7.3-r1.ebuild 662 BLAKE2B 8384280fb3d1ba9a2fd18a7c6fe07b19b819d074b28ce6dd1c0796d082f25af48124e656868e0c00c52d6eb7fbe35b6dc7954373b06e424c0bba2de9526927e2 SHA512 3b4cecb956e9bda8c1f808cfae92522610a54a798ec2490ad5db917a3b7fcaca760fe07fb7d5fd7636c8b0bc9cdf827457bba40a9a7d8e76b9464392a0fd3c65
EBUILD pyqt-distutils-0.7.3.ebuild 575 BLAKE2B daef6a39a7ccfe4f9db7f8d70b9a72b00c718eeacd473c30bba100e07c5599fa28468e808783df905f12a4cc215d13befd9ed00dceceda4203e61153a16386bc SHA512 a073058c31f233847ecde5595ee6c67b11b0e4f51090ee216198f0ffc0c13ec92fd03374cbbaca198cdb371f32ca8a44be1b2a663230164b6f3f3c7f60291411
MISC metadata.xml 321 BLAKE2B 661a2f8ff919b83f83702ce66bf67a5d744a5f971492e068936207f6b6930b623c1adbc548164c62f513f09e8573e6e7ebad48c95fcc55e66dd76aa02eabfa83 SHA512 2dc14ecece4e1f3746e7050c076d7a195faa3558e0692901302163592dba919432568c7771bc2c2a5327c35d37605f8180a637b61d22f36b2c8bc5e744417de6
diff --git a/dev-python/pyqt-distutils/pyqt-distutils-0.7.3-r1.ebuild b/dev-python/pyqt-distutils/pyqt-distutils-0.7.3-r1.ebuild
new file mode 100644
index 000000000000..f827f8f052b6
--- /dev/null
+++ b/dev-python/pyqt-distutils/pyqt-distutils-0.7.3-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+MY_P=${PN/-/_}-${PV}
+DESCRIPTION="distutils extension to work with PyQt applications and UI files"
+HOMEPAGE="
+ https://github.com/ColinDuquesnoy/pyqt_distutils/
+ https://pypi.org/project/pyqt-distutils/
+"
+SRC_URI="
+ https://github.com/ColinDuquesnoy/pyqt_distutils/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/docopt[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest