summaryrefslogtreecommitdiff
path: root/dev-python/pypy3-bin/pypy3-bin-5.10.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-08 21:45:04 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-08 21:45:04 +0000
commit65737cf14a7220bd9a487aa2af4ae0e79bd23e86 (patch)
tree625754b14ae80ac167d1b150c2314b647cd008e6 /dev-python/pypy3-bin/pypy3-bin-5.10.0.ebuild
parent5001a6c7b6da2956f5b17c695b1e0059dc7b8de5 (diff)
gentoo resync : 08.01.2018
Diffstat (limited to 'dev-python/pypy3-bin/pypy3-bin-5.10.0.ebuild')
-rw-r--r--dev-python/pypy3-bin/pypy3-bin-5.10.0.ebuild12
1 files changed, 2 insertions, 10 deletions
diff --git a/dev-python/pypy3-bin/pypy3-bin-5.10.0.ebuild b/dev-python/pypy3-bin/pypy3-bin-5.10.0.ebuild
index 2365033c5b06..2457cda763f7 100644
--- a/dev-python/pypy3-bin/pypy3-bin-5.10.0.ebuild
+++ b/dev-python/pypy3-bin/pypy3-bin-5.10.0.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
-# some random parts need python 2...
+# Test runner needs Python 2.
PYTHON_COMPAT=( python2_7 pypy )
inherit pax-utils python-any-r1 unpacker versionator
@@ -57,8 +57,6 @@ DEPEND="${RDEPEND}
app-arch/lzip
app-arch/xz-utils
test? ( ${PYTHON_DEPS} )"
-# doc? ( ${PYTHON_DEPS}
-# dev-python/sphinx )
S=${WORKDIR}/${MY_P}-src
@@ -90,11 +88,8 @@ src_compile() {
mv pypy/module/cpyext/include/*.h include/ || die
mv pypy/module/cpyext/parse/*.h include/ || die
- #use doc && emake -C pypy/doc/ html
pax-mark m pypy3-c libpypy3-c.so
- #use doc && emake -C pypy/doc html
-
einfo "Generating caches and CFFI modules ..."
# Generate Grammar and PatternGrammar pickles.
@@ -170,9 +165,6 @@ src_install() {
"${ED%/}${dest}"/lib-python/*3/test/test_{tcl,tk,ttk*}.py || die
fi
- # Install docs
- #use doc && dodoc -r pypy/doc/_build/html
-
einfo "Generating caches and byte-compiling ..."
local -x PYTHON=${ED%/}${dest}/pypy3-c