summaryrefslogtreecommitdiff
path: root/dev-python/pypy/pypy-6.0.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-04 08:53:53 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-04 08:53:53 +0100
commite3872864be25f7421015bef2732fa57c0c9fb726 (patch)
tree9cb29a544215119b5c5538e37211b994ce1c87ae /dev-python/pypy/pypy-6.0.0.ebuild
parent480486b52ea64765faf696c88b2c6a26a5a454d4 (diff)
gentoo resync : 04.08.2018
Diffstat (limited to 'dev-python/pypy/pypy-6.0.0.ebuild')
-rw-r--r--dev-python/pypy/pypy-6.0.0.ebuild15
1 files changed, 13 insertions, 2 deletions
diff --git a/dev-python/pypy/pypy-6.0.0.ebuild b/dev-python/pypy/pypy-6.0.0.ebuild
index 286b7be69e1d..3f036775348f 100644
--- a/dev-python/pypy/pypy-6.0.0.ebuild
+++ b/dev-python/pypy/pypy-6.0.0.ebuild
@@ -226,9 +226,20 @@ src_compile() {
src_test() {
# (unset)
- local -x PYTHONDONTWRITEBYTECODE
+ local -x PYTHONDONTWRITEBYTECODE=
+
+ local ignored_tests=(
+ # network
+ --ignore=lib-python/2.7/test/test_urllibnet.py
+ --ignore=lib-python/2.7/test/test_urllib2net.py
+ # lots of free space
+ --ignore=lib-python/2.7/test/test_zipfile64.py
+ # no module named 'worker' -- a lot
+ --ignore=lib-python/2.7/test/test_xpickle.py
+ )
- ./pypy-c ./pypy/test_all.py --pypy=./pypy-c lib-python || die
+ ./pypy-c ./pypy/test_all.py --pypy=./pypy-c -vv \
+ "${ignored_tests[@]}" lib-python || die
}
src_install() {