summaryrefslogtreecommitdiff
path: root/dev-python/pypugjs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /dev-python/pypugjs
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'dev-python/pypugjs')
-rw-r--r--dev-python/pypugjs/Manifest3
-rw-r--r--dev-python/pypugjs/metadata.xml21
-rw-r--r--dev-python/pypugjs/pypugjs-5.9.4.ebuild22
3 files changed, 46 insertions, 0 deletions
diff --git a/dev-python/pypugjs/Manifest b/dev-python/pypugjs/Manifest
new file mode 100644
index 000000000000..b287cddeba44
--- /dev/null
+++ b/dev-python/pypugjs/Manifest
@@ -0,0 +1,3 @@
+DIST pypugjs-5.9.4-tar.gz 42179 BLAKE2B 6ba3ab0b5c4c2828a091c82d5e937ebd1f575f5a9ebd989fbcfa3c17b85471f084d04b641895e8bd4af32ca0c26c430c5d989287824e0bc67f1943fae3bb0caa SHA512 24ebf306a76afab570cb13806d27e12766163bb114a8e4fe20ee5f19eb7311203e8b647eeb2f150efb2f9dfa1db9e56f4218cc3deb15d81f22b12d1b11f83c32
+EBUILD pypugjs-5.9.4.ebuild 516 BLAKE2B f95277eabf5dbaf015a2df9379f730133005a152d890f05703b49af0866616028db374aca89954b3f3b9f5ebde63f90a2b2bc050ae14b69b24b651842aed3e1d SHA512 3d4e8b4cba6486379fe669d01d11ad52907936c2fa27e0b097f02546b8b07dbaea072f635fb2079ff518422d5fccd8bd2eab736a7a294fbb47bfc5fb5ba69cc0
+MISC metadata.xml 730 BLAKE2B 69d4b53c231f47d4526b71c6ed6459834c9e30f54e6b8b6d033ae8cc192d3fd64d99d64c958d29849008b249b8f04f54a9b0503039c79a5893a6d9f0a9209127 SHA512 90ef4ffbbd9f47c60321cc2422e5b6b43377236ba5dcae6584a2c4eba63d0df35131f234a6b98e4df545876d4c0af6bede8a8b406664138a228506378d71b6d4
diff --git a/dev-python/pypugjs/metadata.xml b/dev-python/pypugjs/metadata.xml
new file mode 100644
index 000000000000..5ca7204f4cb5
--- /dev/null
+++ b/dev-python/pypugjs/metadata.xml
@@ -0,0 +1,21 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>dolsen@gentoo.org</email>
+ <name>Brian Dolbec</name>
+ </maintainer>
+ <upstream>
+ <maintainer>
+ <email>andy@freilandkiwis.de</email>
+ <name>Andy Grabow</name>
+ </maintainer>
+ <remote-id type="pypi">pypugjs</remote-id>
+ <remote-id type="github">kakulukia/pypugjs</remote-id>
+ </upstream>
+ <longdescription>PyPugJS is a fork of PyJade with the name Jade changed to PugJS.
+PyPuJS is a high performance port of Jade-lang for python,
+that converts any .pug source to any of the Template-language (Django,
+Jinja2, Mako or Tornado).
+ </longdescription>
+</pkgmetadata>
diff --git a/dev-python/pypugjs/pypugjs-5.9.4.ebuild b/dev-python/pypugjs/pypugjs-5.9.4.ebuild
new file mode 100644
index 000000000000..9b4e376ca260
--- /dev/null
+++ b/dev-python/pypugjs/pypugjs-5.9.4.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pug (Jade) syntax adapter for Django, Jinja2 and Mako templates"
+HOMEPAGE="https://github.com/kakulukia/pypugjs"
+SRC_URI="https://github.com/kakulukia/pypugjs/archive/v${PV}.tar.gz -> ${P}-tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE=""
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/chardet
+"
+DEPEND="${RDEPEND}"