summaryrefslogtreecommitdiff
path: root/dev-python/pyprotocols
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/pyprotocols
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pyprotocols')
-rw-r--r--dev-python/pyprotocols/Manifest4
-rw-r--r--dev-python/pyprotocols/files/SkipTests.patch25
-rw-r--r--dev-python/pyprotocols/metadata.xml8
-rw-r--r--dev-python/pyprotocols/pyprotocols-1.0_pre2306-r1.ebuild46
4 files changed, 83 insertions, 0 deletions
diff --git a/dev-python/pyprotocols/Manifest b/dev-python/pyprotocols/Manifest
new file mode 100644
index 000000000000..f887ea5257e9
--- /dev/null
+++ b/dev-python/pyprotocols/Manifest
@@ -0,0 +1,4 @@
+AUX SkipTests.patch 619 BLAKE2B 69c78ea58acbe0f952df3f7586683b8b41b7857b7e83f6b14d83f5b8135fc1fa574bd3869e312e734b69baead72c6c782d8c27a95768ae89c9695c5cc677b8d2 SHA512 b4f37fdcb0eb10d58813d3bfe776de9a56549f768eb974ec2a8818ca891181a1551cf8c8ee99865aade77f4aef330e617053bde58824f288a876da0beb4f8d51
+DIST PyProtocols-1.0a0dev_r2306.tar.gz 218555 BLAKE2B 77862a59343b21a97f1bbc5281f397652108912669e6e550e2ae7ad7f4e95c181b8315a940f5b737e20468fba1bec42b4539571ee8ab54a41737fcdc5e3e7a70 SHA512 1f18be9548ae29b6111dccd158f5706f3a1ed7074152e9ef2e0d17caaad2227d3f613b50b602b3b1d47b5db7f53e583fce4e06b3e23916ac0daf7a92bcd66ccc
+EBUILD pyprotocols-1.0_pre2306-r1.ebuild 1196 BLAKE2B 25225fda7cb84531dd81ae32622b0cba18d4c2de1555f73d12518b20322fe5ef16c5d87185bf1a3b9ae9c2427d4f7844a6f36c3f1ded21fbc0e6b905f32d040a SHA512 55ca37683aec6a671aea96f1b6b18165e386e65a2e777b4efdf2671aeaf234cf7df015ba99fe9c3fdbaaac2917bbf53d79bc463a4f0cde815b79edb81b5b8f1e
+MISC metadata.xml 236 BLAKE2B 167eb58da19caba0e03167e2f209e118ce8a468851bca2790a0353112848fffcd72522497e5f951bf5c6eafa9691fa2a1ad980843cb4170a8194f3b8178ebe16 SHA512 0f2c2a0401b53543eac90eafdd4d11c5913be07f47b968e2892ca92c265adbd9564f02a491ff2607d7031194ba3e50c7720851537341b1541120821c487147a3
diff --git a/dev-python/pyprotocols/files/SkipTests.patch b/dev-python/pyprotocols/files/SkipTests.patch
new file mode 100644
index 000000000000..293f0a2a0626
--- /dev/null
+++ b/dev-python/pyprotocols/files/SkipTests.patch
@@ -0,0 +1,25 @@
+--- a/src/protocols/tests/__init__.py
++++ b/src/protocols/tests/__init__.py
+@@ -256,22 +256,6 @@
+ makeSuite(GenerationTests,'check'),
+ ]
+
+- try:
+- import zope.interface
+- except ImportError:
+- pass
+- else:
+- from protocols.tests import test_zope
+- tests.append( test_zope.test_suite() )
+-
+- try:
+- from twisted.python.components import Interface
+- except (ImportError, SystemError):
+- pass
+- else:
+- from protocols.tests import test_twisted
+- tests.append( test_twisted.test_suite() )
+-
+ return TestSuite(
+ tests
+ )
diff --git a/dev-python/pyprotocols/metadata.xml b/dev-python/pyprotocols/metadata.xml
new file mode 100644
index 000000000000..9e5274c5b4ae
--- /dev/null
+++ b/dev-python/pyprotocols/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+</maintainer>
+</pkgmetadata>
diff --git a/dev-python/pyprotocols/pyprotocols-1.0_pre2306-r1.ebuild b/dev-python/pyprotocols/pyprotocols-1.0_pre2306-r1.ebuild
new file mode 100644
index 000000000000..b02638a61800
--- /dev/null
+++ b/dev-python/pyprotocols/pyprotocols-1.0_pre2306-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1 flag-o-matic
+
+MY_PN="PyProtocols"
+MY_P="${MY_PN}-${PV/_pre/a0dev_r}"
+
+DESCRIPTION="Extends the PEP 246 adapt function with a new 'declaration API'"
+HOMEPAGE="http://peak.telecommunity.com/PyProtocols.html https://pypi.org/project/PyProtocols/ \
+ http://svn.eby-sarna.com/PyProtocols/"
+SRC_URI="mirror://gentoo/${MY_P}.tar.gz"
+
+LICENSE="|| ( PSF-2 ZPL )"
+SLOT="0"
+KEYWORDS="amd64 ~ia64 ppc x86 ~amd64-linux ~x86-linux ~x64-macos ~x86-macos"
+IUSE=""
+
+RDEPEND=">=dev-python/decoratortools-1.4[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ >=dev-python/pyrex-0.9.9[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]"
+
+S="${WORKDIR}/${MY_PN}"
+
+PATCHES=( "${FILESDIR}"/SkipTests.patch )
+DOCS=( CHANGES.txt README.txt UPGRADING.txt )
+
+python_prepare_all() {
+ # Rm peripheral & rogue failing tests
+ rm -f src//protocols/tests/{test_twisted.py,test_zope.py} || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_configure_all() {
+ append-flags -fno-strict-aliasing
+}
+
+python_test() {
+ esetup.py test || die "Tests failed under ${EPYTHON}"
+}