summaryrefslogtreecommitdiff
path: root/dev-python/pypresence/pypresence-4.3.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-10 10:26:59 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-10 10:26:59 +0100
commit870be9524d5a85e6be7803b3f4eae71fd93cb530 (patch)
tree69e71d2202044c302e1f9209a0a40d7418d8e48d /dev-python/pypresence/pypresence-4.3.0.ebuild
parent9e8f96c1b33dc01bc5dfbed0cfb2702bb299f1e0 (diff)
gentoo auto-resync : 10:07:2023 - 10:26:59
Diffstat (limited to 'dev-python/pypresence/pypresence-4.3.0.ebuild')
-rw-r--r--dev-python/pypresence/pypresence-4.3.0.ebuild19
1 files changed, 19 insertions, 0 deletions
diff --git a/dev-python/pypresence/pypresence-4.3.0.ebuild b/dev-python/pypresence/pypresence-4.3.0.ebuild
new file mode 100644
index 000000000000..ceadf33a5aa0
--- /dev/null
+++ b/dev-python/pypresence/pypresence-4.3.0.ebuild
@@ -0,0 +1,19 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+DESCRIPTION="Complete Discord IPC and Rich Presence wrapper library in Python"
+HOMEPAGE="https://github.com/qwertyquerty/pypresence"
+SRC_URI="https://github.com/qwertyquerty/pypresence/archive/refs/tags/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_sphinx docs/sphinx dev-python/alabaster