summaryrefslogtreecommitdiff
path: root/dev-python/pyplusplus/pyplusplus-1.0.0_p20131206.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/pyplusplus/pyplusplus-1.0.0_p20131206.ebuild
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pyplusplus/pyplusplus-1.0.0_p20131206.ebuild')
-rw-r--r--dev-python/pyplusplus/pyplusplus-1.0.0_p20131206.ebuild43
1 files changed, 43 insertions, 0 deletions
diff --git a/dev-python/pyplusplus/pyplusplus-1.0.0_p20131206.ebuild b/dev-python/pyplusplus/pyplusplus-1.0.0_p20131206.ebuild
new file mode 100644
index 000000000000..b6ee0e3bb1ab
--- /dev/null
+++ b/dev-python/pyplusplus/pyplusplus-1.0.0_p20131206.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Object-oriented framework for creating a code generator for Boost.Python library"
+HOMEPAGE="http://www.language-binding.net/"
+
+if [[ ${PV} == 9999 ]]; then
+ ESVN_REPO_URI="https://svn.code.sf.net/p/pygccxml/svn/${PN}_dev"
+ inherit subversion
+ S=${WORKDIR}/${PN}_dev
+else
+ SRC_URI="https://dev.gentoo.org/~heroxbd/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="freedist Boost-1.0"
+SLOT="0"
+IUSE="examples numpy"
+
+DEPEND="app-arch/unzip
+ numpy? ( dev-python/numpy[${PYTHON_USEDEP}] )"
+RDEPEND="dev-python/pygccxml[${PYTHON_USEDEP}]"
+
+src_prepare() {
+ use numpy && epatch --binary "${FILESDIR}"/${PN}-1.0.0_p20131206-numpy.patch
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ "${PYTHON}" unittests/test_all.py || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+
+ distutils-r1_python_install_all
+}