summaryrefslogtreecommitdiff
path: root/dev-python/pyplusplus/pyplusplus-1.0.0_p20131206.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-python/pyplusplus/pyplusplus-1.0.0_p20131206.ebuild
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pyplusplus/pyplusplus-1.0.0_p20131206.ebuild')
-rw-r--r--dev-python/pyplusplus/pyplusplus-1.0.0_p20131206.ebuild43
1 files changed, 0 insertions, 43 deletions
diff --git a/dev-python/pyplusplus/pyplusplus-1.0.0_p20131206.ebuild b/dev-python/pyplusplus/pyplusplus-1.0.0_p20131206.ebuild
deleted file mode 100644
index b6ee0e3bb1ab..000000000000
--- a/dev-python/pyplusplus/pyplusplus-1.0.0_p20131206.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1
-
-DESCRIPTION="Object-oriented framework for creating a code generator for Boost.Python library"
-HOMEPAGE="http://www.language-binding.net/"
-
-if [[ ${PV} == 9999 ]]; then
- ESVN_REPO_URI="https://svn.code.sf.net/p/pygccxml/svn/${PN}_dev"
- inherit subversion
- S=${WORKDIR}/${PN}_dev
-else
- SRC_URI="https://dev.gentoo.org/~heroxbd/${P}.tar.xz"
- KEYWORDS="~amd64 ~x86"
-fi
-
-LICENSE="freedist Boost-1.0"
-SLOT="0"
-IUSE="examples numpy"
-
-DEPEND="app-arch/unzip
- numpy? ( dev-python/numpy[${PYTHON_USEDEP}] )"
-RDEPEND="dev-python/pygccxml[${PYTHON_USEDEP}]"
-
-src_prepare() {
- use numpy && epatch --binary "${FILESDIR}"/${PN}-1.0.0_p20131206-numpy.patch
- distutils-r1_src_prepare
-}
-
-python_test() {
- "${PYTHON}" unittests/test_all.py || die "Tests fail with ${EPYTHON}"
-}
-
-python_install_all() {
- use examples && local EXAMPLES=( examples/. )
-
- distutils-r1_python_install_all
-}