summaryrefslogtreecommitdiff
path: root/dev-python/pyphen
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-06-15 14:57:03 +0100
commitd18bf1e01b65ee4bf0c804e2843b282d3d4e5d7c (patch)
tree4a95cbc6ffdf13bad6ecbc7f8d5af99631984123 /dev-python/pyphen
parente748ba9741f6540f4675c23e3e37b73e822c13a4 (diff)
gentoo resync : 15.06.2021
Diffstat (limited to 'dev-python/pyphen')
-rw-r--r--dev-python/pyphen/Manifest4
-rw-r--r--dev-python/pyphen/pyphen-0.10.0.ebuild18
2 files changed, 7 insertions, 15 deletions
diff --git a/dev-python/pyphen/Manifest b/dev-python/pyphen/Manifest
index 96b0192ee33d..b7205ea38434 100644
--- a/dev-python/pyphen/Manifest
+++ b/dev-python/pyphen/Manifest
@@ -1,3 +1,3 @@
-DIST pyphen-0.10.0.tar.gz 1894118 BLAKE2B c33283d6eb3dd7affb52b91826fa0f8fab8ec8f858158e905e8487dc2ad8c77a88e4b25699ed6272d246bcf8a926560e18ec224f59703452ea1ad5c921e4fb4b SHA512 b6d789ca6eb010c1c79b28a9a0e68620ea5600adc43111bed5dbda3cb8b3a4c8c05caa3fb44ea60b0ef4a20272f17cf5e6fe61f0d1e48038395407ff53da7a92
-EBUILD pyphen-0.10.0.ebuild 675 BLAKE2B 20a3feab69e5de5c89552aec94a38f752f505a8ec1fd219f7a0bb63541f4245152be76a5d7e8f69fe56e4005de9802030c47b2db42e031cee453f9bc3b4c8553 SHA512 69f6b7d251e5ad1f5506baa54f3e8e65bc43489fde18a22190c0f4a838773874f87f98e407b217573bcc72af87e0a483bb40962c8bd13776baf220d26f71969f
+DIST Pyphen-0.10.0.tar.gz 1894118 BLAKE2B c33283d6eb3dd7affb52b91826fa0f8fab8ec8f858158e905e8487dc2ad8c77a88e4b25699ed6272d246bcf8a926560e18ec224f59703452ea1ad5c921e4fb4b SHA512 b6d789ca6eb010c1c79b28a9a0e68620ea5600adc43111bed5dbda3cb8b3a4c8c05caa3fb44ea60b0ef4a20272f17cf5e6fe61f0d1e48038395407ff53da7a92
+EBUILD pyphen-0.10.0.ebuild 515 BLAKE2B 0a1542e49d1116483571bbc7f6fd921f86646f1dbdf9741a5b5224a46796678d4442b9166818ac50ae8d6664d66962da3515539ee34d1b0fbdb96e567e9de494 SHA512 e68b9996049d39c91d52842b2180017f2a066808b75f24c59ed1fe46abb81b6acff6cc72878272fc64290cddd29d5d4bf4e458546555adf289649a079c5c21c5
MISC metadata.xml 409 BLAKE2B 3ec65099621f94904aea69465bdc2163554677e4312d51f925df9d792deb790aa1511b0c9e8fa86a4416f083b1f8b0072a71b88480c46e46ebe30165f560a63f SHA512 4462817e8689c52a47fc71cf2f73204c8a0963bffed85fd803993236aa2d36924c92a232d0bee5b3153a6dbad85c5808c2cf42df5ab8b6bd585d5045650802a8
diff --git a/dev-python/pyphen/pyphen-0.10.0.ebuild b/dev-python/pyphen/pyphen-0.10.0.ebuild
index 99764ca32724..37507a56effb 100644
--- a/dev-python/pyphen/pyphen-0.10.0.ebuild
+++ b/dev-python/pyphen/pyphen-0.10.0.ebuild
@@ -1,30 +1,22 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="7"
-PYTHON_COMPAT=( python3_{7,8,9} )
-DISTUTILS_USE_SETUPTOOLS=bdepend
+PYTHON_COMPAT=( python3_{8..10} )
inherit distutils-r1
DESCRIPTION="Python module for hyphenation using hunspell dictionaries"
-MY_PN="Pyphen"
-MY_P="${MY_PN}-${PV}"
-SRC_URI="https://github.com/Kozea/${MY_PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
HOMEPAGE="https://github.com/Kozea/Pyphen"
+SRC_URI="https://github.com/Kozea/Pyphen/archive/${PV}.tar.gz -> ${P^}.tar.gz"
+S=${WORKDIR}/${P^}
LICENSE="GPL-2+ LGPL-2+ MPL-1.1"
SLOT="0"
KEYWORDS="amd64 x86"
-IUSE=""
-
-RDEPEND=""
-DEPEND="test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
-
-S="${WORKDIR}/${MY_P}"
distutils_enable_tests pytest
python_test() {
- pytest -v test.py || die
+ epytest test.py
}