summaryrefslogtreecommitdiff
path: root/dev-python/pyphen/pyphen-0.13.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-11-17 12:56:42 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-11-17 12:56:42 +0000
commit34fb4543abc1dae6f74171ad8dc80fa64636a941 (patch)
tree5923cd4dc2a560dba9b618db67713ae10cf92f75 /dev-python/pyphen/pyphen-0.13.1.ebuild
parent1536d928ae095e00db8775fecca580c10adc0af8 (diff)
gentoo auto-resync : 17:11:2022 - 12:56:42
Diffstat (limited to 'dev-python/pyphen/pyphen-0.13.1.ebuild')
-rw-r--r--dev-python/pyphen/pyphen-0.13.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/pyphen/pyphen-0.13.1.ebuild b/dev-python/pyphen/pyphen-0.13.1.ebuild
new file mode 100644
index 000000000000..8e9142ded36e
--- /dev/null
+++ b/dev-python/pyphen/pyphen-0.13.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python module for hyphenation using hunspell dictionaries"
+HOMEPAGE="
+ https://github.com/Kozea/Pyphen/
+ https://pypi.org/project/pyphen/
+"
+SRC_URI="
+ https://github.com/Kozea/Pyphen/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+S=${WORKDIR}/${P^}
+
+LICENSE="GPL-2+ LGPL-2+ MPL-1.1"
+SLOT="0"
+KEYWORDS="~amd64 ~riscv ~x86"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest -o addopts=
+}