summaryrefslogtreecommitdiff
path: root/dev-python/pypeg2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/pypeg2
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pypeg2')
-rw-r--r--dev-python/pypeg2/Manifest4
-rw-r--r--dev-python/pypeg2/files/pypeg2-2.15.1-test.patch12
-rw-r--r--dev-python/pypeg2/metadata.xml12
-rw-r--r--dev-python/pypeg2/pypeg2-2.15.2.ebuild31
4 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/pypeg2/Manifest b/dev-python/pypeg2/Manifest
new file mode 100644
index 000000000000..e12f3bb2b504
--- /dev/null
+++ b/dev-python/pypeg2/Manifest
@@ -0,0 +1,4 @@
+AUX pypeg2-2.15.1-test.patch 399 BLAKE2B 64afae813084e2bcceb3354d6a9819425f5454d7febbb3df12d7b7f73329bfeed1a93fd7bbd046c69899f26757d984fd70964e13809ba9bb30305b80d35cdbc8 SHA512 20428aa41858da3b73a262ec2f36aed0df8626999eae27438a6bad1908b1dc79056ab33069c273aae56eabc02dfd0c080daaf42fee7e7c92ec32b95244ba41c4
+DIST pyPEG2-2.15.2.tar.gz 40334 BLAKE2B 7a171824da4c0ccc3bfaef4e429efb16f5c8c4e03dd47c5cd59656a51fe37c9d0b3940e58e2f321a4d9976f66935fd5b9d526d24bd1e0342ef15a3a1341e77a3 SHA512 f78e3b1294169167809c5fe05f2a69af2bd6c7c4c1bcbebafb4aa6b8ae6ead181a46b051e41193bc31f49c4b4fa7b1ef231d172217c11d301d0ee21d8e411b6f
+EBUILD pypeg2-2.15.2.ebuild 715 BLAKE2B bac1a27d543a028ab6c5b861a3129f351075687556e7d2dc2b142150b9feaf682f8509c0bf04568eb74b94214b07157cfba52d5535c37fd549438b4b0389b4d4 SHA512 5f608dd6fe3222cd123d06165a2c03233a50c63e51a5ef3c8a3f5b88ac4a0a1b203a13f950ee95f9089a15bb69fd2c39745141a6256c586ae52d7650d1f7fcae
+MISC metadata.xml 362 BLAKE2B c34e5f667750e99f16f44361c62c79d138767c94e664be039f81f7b7fb6f295e6610aeca962ece7097dfbc1372e92e697ad99572c036910352362379eb3ab4cc SHA512 7eb0a3fbe48ee8f34bb9f697aa951faece1ce5da90319a5bd8f9958d569eebd2c91539d0d1bd46c51cdc77ddb5c858bb6d158be7268666af668a935e1c4998e7
diff --git a/dev-python/pypeg2/files/pypeg2-2.15.1-test.patch b/dev-python/pypeg2/files/pypeg2-2.15.1-test.patch
new file mode 100644
index 000000000000..6ca8839d7776
--- /dev/null
+++ b/dev-python/pypeg2/files/pypeg2-2.15.1-test.patch
@@ -0,0 +1,12 @@
+Drop seemingly wrong test line that throws an AttributeError.
+
+--- pyPEG2-2.15.1/pypeg2/test/test_pyPEG2.py
++++ pyPEG2-2.15.1/pypeg2/test/test_pyPEG2.py
+@@ -255,7 +255,6 @@
+ def runTest(self):
+ r = pypeg2.parse("!all", type(self).C1)
+ self.assertEqual(str(r), "all")
+- self.assertEqual(r._ignore1, None)
+
+ class ParseOmitTestCase(ParserTestCase):
+ def runTest(self):
diff --git a/dev-python/pypeg2/metadata.xml b/dev-python/pypeg2/metadata.xml
new file mode 100644
index 000000000000..1194ecffea20
--- /dev/null
+++ b/dev-python/pypeg2/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">pyPEG2</remote-id>
+ <remote-id type="bitbucket">fdik/pypeg</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pypeg2/pypeg2-2.15.2.ebuild b/dev-python/pypeg2/pypeg2-2.15.2.ebuild
new file mode 100644
index 000000000000..d4956c2fa699
--- /dev/null
+++ b/dev-python/pypeg2/pypeg2-2.15.2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+MY_PN=pyPEG2
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="An intrinsic PEG Parser-Interpreter for Python"
+HOMEPAGE="https://fdik.org/pyPEG/
+ https://bitbucket.org/fdik/pypeg/
+ https://pypi.org/project/pyPEG2/"
+SRC_URI="mirror://pypi/${PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/lxml[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+PATCHES=( "${FILESDIR}"/${PN}-2.15.1-test.patch )
+
+python_test() {
+ "${PYTHON}" -m unittest discover || die "Tests failed with ${EPYTHON}"
+}