summaryrefslogtreecommitdiff
path: root/dev-python/pypdf
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-19 05:39:40 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-19 05:39:40 +0000
commitb24782302154e447b59c3f719970f951cd15cd38 (patch)
tree463a954988b9099fbc02967de0cf25b250d0caf7 /dev-python/pypdf
parent753ad9170f0d68e7f525f1931bc6ebf359268b29 (diff)
gentoo auto-resync : 19:02:2024 - 05:39:40
Diffstat (limited to 'dev-python/pypdf')
-rw-r--r--dev-python/pypdf/Manifest2
-rw-r--r--dev-python/pypdf/pypdf-4.0.2.ebuild59
2 files changed, 61 insertions, 0 deletions
diff --git a/dev-python/pypdf/Manifest b/dev-python/pypdf/Manifest
index a3535b8b020b..530821f9acca 100644
--- a/dev-python/pypdf/Manifest
+++ b/dev-python/pypdf/Manifest
@@ -1,5 +1,7 @@
AUX pypdf-4.0.1-pytest-8.patch 3106 BLAKE2B bc5ed79dc84cd8e826e21ea839ec926a57fe32f94446f85ecb48418edf20b58ee2298929ea96c65ed2a7848e8904a2d2c63221f3d71a1d8ea86bdba226cc52f2 SHA512 08106dc12e0f60453658925785e05673c62acbff7cb509d7e14416d0b033ea5d6f39ee955b0328ba988ae3546e8e475d1819b5ec68c0b1e7b5d8c8658f5ac5ae
DIST pypdf-4.0.1.gh.tar.gz 7992979 BLAKE2B a072b50d177a89133bd5c7a74cae1d4f4ed5d6bcb1d78c68573c98f792a28a8ded26b5a82743a70ec2cd41651db8a19580cc48b0376c0dfe2f422826311914c3 SHA512 e9170b75ab00ce86580194bfa64ff3a31eb6fca62adc006478fcee3a78a99df269c75857672838c2b752b78b19174883cecb2eea5586878f81eb75474fabee6d
+DIST pypdf-4.0.2.gh.tar.gz 7992844 BLAKE2B ddd38e8c27230c6425de2677c1f2bd6f521c87e4b10e4791ed8d2b961c7c9e210b49b6d684780f16fb1620db7c123aed9ee548b381d54ae881a6e64305b26379 SHA512 4539f2c1c4b98e27dd3f43c7aa44efe03e80c8089f655130dd80dceee85afae235bc819b9309bc36653c953741ec3b998ccbb1274c28abf144792ae44147efd9
DIST pypdf-sample-files-964fb47b0fbfa89864680582640ae4eedf143890.gh.tar.gz 11668924 BLAKE2B 0c7d8e7cfb2f9d06d7633d57b691ba473d33cfcb58d2f1f83661cef9d755340d05db8767771a385d0ba88aa904f84b8bc7eafdb5d4f614b7a21a2d138572316f SHA512 28070b575273b6fee3173e797ed5bac618f8e8aca16d0122dcf3b4b16cedbcad69b84a9bc4be65037695597bcc1fa7898cdf766c37915c49f880a0c6ca057e68
EBUILD pypdf-4.0.1.ebuild 1496 BLAKE2B f4b4e9e7a34fab791f8fdff920a43f7b8b96a9a276aeaf0879bb009d7e5dffdf0750fc9d44d337ec0ed96a454bf7ebf477aed296d46522fb43b8dbc76f6abbe8 SHA512 1b0219c832b84b8d6f08b729a6b823038c54db14e0b1fdbfd692f0590350c5f196183e7836ffead0d78645cec4c9db79f18924ab85720b5bad8f37db7040667e
+EBUILD pypdf-4.0.2.ebuild 1406 BLAKE2B 2a65acc5e208087e453bc1a7c4ecc9dc3daf37ed9bc12f9cbe021846f5c8135f2ed26acb31a49cdbd4328d4f1441f12541112a409728966596690be2e5cdd403 SHA512 f371a293660fa36cc4f2e360877e10d7fdaf866419dd723c2abbec2cfd74e7bf13d1e4d8b07d4f7333807435ada6d5c8765cd59a00a4c8c3031d30fb1ef5794c
MISC metadata.xml 373 BLAKE2B a829b7048eb3a95caeb1be83b6172603df6a031d40995294f2687bf3c3cb70e66fafb9ba8339d9979fc85f5936b9552963a8fcd072a20661fa78f3aa3c4b89c0 SHA512 775ac2de487f11fba1ea8d283b42b9ef56e42cd95ea11f50a06b099420e69c0567f65c506b14891ac641da90ea05ca70da4f8a3e4a028cf41bdbc823021dccfe
diff --git a/dev-python/pypdf/pypdf-4.0.2.ebuild b/dev-python/pypdf/pypdf-4.0.2.ebuild
new file mode 100644
index 000000000000..f0cc9485cc72
--- /dev/null
+++ b/dev-python/pypdf/pypdf-4.0.2.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=flit
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1
+
+SAMPLE_COMMIT=964fb47b0fbfa89864680582640ae4eedf143890
+DESCRIPTION="Python library to work with PDF files"
+HOMEPAGE="
+ https://pypi.org/project/pypdf/
+ https://github.com/py-pdf/pypdf/
+"
+SRC_URI="
+ https://github.com/py-pdf/pypdf/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ test? (
+ https://github.com/py-pdf/sample-files/archive/${SAMPLE_COMMIT}.tar.gz
+ -> ${PN}-sample-files-${SAMPLE_COMMIT}.gh.tar.gz
+ )
+"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc64 ~x86"
+
+BDEPEND="
+ test? (
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ >=dev-python/pillow-8.0.0[jpeg,jpeg2k,tiff,zlib,${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+src_unpack() {
+ default
+ if use test; then
+ mv "sample-files-${SAMPLE_COMMIT}"/* "${S}"/sample-files/ || die
+ fi
+}
+
+python_test() {
+ local EPYTEST_DESELECT=(
+ tests/test_reader.py::test_decode_permissions
+ tests/test_workflows.py::test_text_extraction_layout_mode
+ # rely on -Werror
+ tests/test_utils.py::test_deprecate_no_replacement
+ tests/test_workflows.py::test_orientations
+ tests/test_writer.py::test_remove_image_per_type
+ )
+
+ local -x PYTEST_DISABLE_PLUGIN_AUTOLOAD=1
+ epytest -o addopts= -m "not enable_socket"
+}