summaryrefslogtreecommitdiff
path: root/dev-python/pyparted/pyparted-3.11.4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-02-17 01:16:38 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-02-17 01:16:38 +0000
commit53cba99042fa967e2a93da9f8db806fe2d035543 (patch)
tree9780d3b87dfc6bdebc6b7b7d15af1ecb813c6853 /dev-python/pyparted/pyparted-3.11.4.ebuild
parent71deace00d1a2b091313fe137ab7092418c6f87c (diff)
gentoo resync : 17.02.2020
Diffstat (limited to 'dev-python/pyparted/pyparted-3.11.4.ebuild')
-rw-r--r--dev-python/pyparted/pyparted-3.11.4.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/pyparted/pyparted-3.11.4.ebuild b/dev-python/pyparted/pyparted-3.11.4.ebuild
new file mode 100644
index 000000000000..5dcdba1e16b1
--- /dev/null
+++ b/dev-python/pyparted/pyparted-3.11.4.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{6,8} )
+inherit distutils-r1 flag-o-matic
+
+DESCRIPTION="Python bindings for sys-block/parted"
+HOMEPAGE="https://github.com/rhinstaller/pyparted/"
+SRC_URI="https://github.com/rhinstaller/pyparted/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+
+RDEPEND="
+ >=sys-block/parted-3.1
+ dev-python/decorator[${PYTHON_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+
+distutils_enable_tests unittest
+
+src_configure() {
+ append-cflags -fcommon
+ default
+}