summaryrefslogtreecommitdiff
path: root/dev-python/pyotp/pyotp-2.8.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-12-14 09:29:38 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-12-14 09:29:38 +0000
commit05a3b7c2189f095dfc46fbb03d4b3e801d3dc13a (patch)
tree46ab17fba7d43e3132d97ee97ebd604dea996018 /dev-python/pyotp/pyotp-2.8.0.ebuild
parentc73b611d606bc14760bad8592f5bfec28c9b1079 (diff)
gentoo auto-resync : 14:12:2022 - 09:29:38
Diffstat (limited to 'dev-python/pyotp/pyotp-2.8.0.ebuild')
-rw-r--r--dev-python/pyotp/pyotp-2.8.0.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/dev-python/pyotp/pyotp-2.8.0.ebuild b/dev-python/pyotp/pyotp-2.8.0.ebuild
new file mode 100644
index 000000000000..1309f77d2d96
--- /dev/null
+++ b/dev-python/pyotp/pyotp-2.8.0.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="PyOTP is a Python library for generating and verifying one-time passwords"
+HOMEPAGE="
+ https://github.com/pyauth/pyotp/
+ https://pypi.org/project/pyotp/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+distutils_enable_tests unittest