summaryrefslogtreecommitdiff
path: root/dev-python/pyotp/pyotp-2.6.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
commitc8d60dada2ec8eb48b2d2b290cd6683ccec40e39 (patch)
treec44943ee0563a3fa957716de909fed683117fcb9 /dev-python/pyotp/pyotp-2.6.0.ebuild
parent69051588e2f955485fe5d45d45e616bc60a2de57 (diff)
gentoo (valentine's day) resync : 14.02.2021
Diffstat (limited to 'dev-python/pyotp/pyotp-2.6.0.ebuild')
-rw-r--r--dev-python/pyotp/pyotp-2.6.0.ebuild18
1 files changed, 18 insertions, 0 deletions
diff --git a/dev-python/pyotp/pyotp-2.6.0.ebuild b/dev-python/pyotp/pyotp-2.6.0.ebuild
new file mode 100644
index 000000000000..cf8967a7eb75
--- /dev/null
+++ b/dev-python/pyotp/pyotp-2.6.0.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="PyOTP is a Python library for generating and verifying one-time passwords."
+HOMEPAGE="https://github.com/pyauth/pyotp https://pypi.org/project/pyotp/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+distutils_enable_tests unittest