summaryrefslogtreecommitdiff
path: root/dev-python/pyotherside
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-07 20:12:29 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-07 20:12:29 +0100
commit1f45d596fc838ad34ca4c17b7db7882f5048cec2 (patch)
treee5e2e397951ee044e0751efacb8b59ea81f9b605 /dev-python/pyotherside
parent32c7b79bcc8a67e6bc6516adbc729e83f957a368 (diff)
gentoo auto-resync : 07:08:2022 - 20:12:29
Diffstat (limited to 'dev-python/pyotherside')
-rw-r--r--dev-python/pyotherside/Manifest2
-rw-r--r--dev-python/pyotherside/pyotherside-1.5.9.ebuild21
2 files changed, 12 insertions, 11 deletions
diff --git a/dev-python/pyotherside/Manifest b/dev-python/pyotherside/Manifest
index ac05e611de48..e35006999516 100644
--- a/dev-python/pyotherside/Manifest
+++ b/dev-python/pyotherside/Manifest
@@ -1,3 +1,3 @@
DIST pyotherside-1.5.9.tar.gz 185230 BLAKE2B 7130f17f29ed07cefc641d77631db46d08f3bd836c8517427e38fb454cbf34c2e875bb46798b3d785aa68064c24f154ed166617cde263f722e77eac6d0903980 SHA512 62c171b273b921d8e0220c7b73f0ff95a0a911eb3785cc37f3dab2ec624e54301ac5fbccfb57cac6a4bee967728624d4738b03aff0c5762452b99674cdff6ab2
-EBUILD pyotherside-1.5.9.ebuild 817 BLAKE2B 798467991403aff2e5696fb1613c756fb5e0f8b3887e1207aa41190d8eabbf966c0756f32181389b80cb7cc7ed7ac0b4aa9d1f082e51ca63fb288abbbf6f1516 SHA512 c99bb9c4bf3acbd563fc9569ffcc66b9d4d0424e8def86413c214d92974b63d8d4f342fe33fd41df3490979cc2493642b0415f974be9bdb1f2b929c858079f2d
+EBUILD pyotherside-1.5.9.ebuild 838 BLAKE2B 02180271c9cc5793dc50a05b1431f18020a593c6312ff3722acd27d81d1e39b50beab5e9fe12bed62f8b13861718b075476d12b7d741b0b8e2ec8ce036922213 SHA512 e9dbc395b578731ad81f3fb98a0102cf8e1ee49b60845cccf811065455c8401e7e52a3a1029510e45e5d7cb882904b2c9bab5809b87d0dd5792f4f6579a620c8
MISC metadata.xml 326 BLAKE2B c323223e1038b40f67b25b1f13a4f5fec61175ef0b73bd3ec3a4228bb51b0a41e0f27ca2f47ec9f2b595e07a83358c74f254054d06b4488ff25d2a1c046899b4 SHA512 9d4649f09f1a00a9aa4a8eeb4e535ceff6b924253cd3ac93a8c0d1f6fe2a94c02a7f14f5b722b7b39744ab7331cd3efb57dc59bcb7ab6fb5ce59f692c0f2718a
diff --git a/dev-python/pyotherside/pyotherside-1.5.9.ebuild b/dev-python/pyotherside/pyotherside-1.5.9.ebuild
index 8c01e30377f8..2653359244df 100644
--- a/dev-python/pyotherside/pyotherside-1.5.9.ebuild
+++ b/dev-python/pyotherside/pyotherside-1.5.9.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{8..11} )
inherit qmake-utils python-single-r1
@@ -14,28 +14,29 @@ SRC_URI="https://github.com/thp/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="ISC"
SLOT="0"
KEYWORDS="~amd64 ~ppc64 ~riscv"
-REQUIRED_USE=${PYTHON_REQUIRED_USE}
-# Requires active X display
-RESTRICT="test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-RDEPEND="${PYTHON_DEPS}
+RDEPEND="
+ ${PYTHON_DEPS}
dev-qt/qtcore:5
dev-qt/qtdeclarative:5
dev-qt/qtgui:5
- dev-qt/qtsvg:5
- "
+ dev-qt/qtsvg:5"
DEPEND="${RDEPEND}"
src_prepare() {
- sed -i -e "s/qtquicktests//" pyotherside.pro || die
-
default
+ sed -i -e "s/qtquicktests//" pyotherside.pro || die
}
src_configure() {
eqmake5
}
+src_test() {
+ QT_QPA_PLATFORM="offscreen" tests/tests || die
+}
+
src_install() {
emake install INSTALL_ROOT="${D}"
}