summaryrefslogtreecommitdiff
path: root/dev-python/pyotherside/pyotherside-1.5.9.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-07 20:12:29 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-07 20:12:29 +0100
commit1f45d596fc838ad34ca4c17b7db7882f5048cec2 (patch)
treee5e2e397951ee044e0751efacb8b59ea81f9b605 /dev-python/pyotherside/pyotherside-1.5.9.ebuild
parent32c7b79bcc8a67e6bc6516adbc729e83f957a368 (diff)
gentoo auto-resync : 07:08:2022 - 20:12:29
Diffstat (limited to 'dev-python/pyotherside/pyotherside-1.5.9.ebuild')
-rw-r--r--dev-python/pyotherside/pyotherside-1.5.9.ebuild21
1 files changed, 11 insertions, 10 deletions
diff --git a/dev-python/pyotherside/pyotherside-1.5.9.ebuild b/dev-python/pyotherside/pyotherside-1.5.9.ebuild
index 8c01e30377f8..2653359244df 100644
--- a/dev-python/pyotherside/pyotherside-1.5.9.ebuild
+++ b/dev-python/pyotherside/pyotherside-1.5.9.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=8
-PYTHON_COMPAT=( python3_{8..10} )
+PYTHON_COMPAT=( python3_{8..11} )
inherit qmake-utils python-single-r1
@@ -14,28 +14,29 @@ SRC_URI="https://github.com/thp/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="ISC"
SLOT="0"
KEYWORDS="~amd64 ~ppc64 ~riscv"
-REQUIRED_USE=${PYTHON_REQUIRED_USE}
-# Requires active X display
-RESTRICT="test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-RDEPEND="${PYTHON_DEPS}
+RDEPEND="
+ ${PYTHON_DEPS}
dev-qt/qtcore:5
dev-qt/qtdeclarative:5
dev-qt/qtgui:5
- dev-qt/qtsvg:5
- "
+ dev-qt/qtsvg:5"
DEPEND="${RDEPEND}"
src_prepare() {
- sed -i -e "s/qtquicktests//" pyotherside.pro || die
-
default
+ sed -i -e "s/qtquicktests//" pyotherside.pro || die
}
src_configure() {
eqmake5
}
+src_test() {
+ QT_QPA_PLATFORM="offscreen" tests/tests || die
+}
+
src_install() {
emake install INSTALL_ROOT="${D}"
}