summaryrefslogtreecommitdiff
path: root/dev-python/pyotherside/pyotherside-1.5.8.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-10-13 22:19:36 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-10-14 23:22:23 +0100
commit4b19be30aa626b327c885dae62c559ec0e9fb935 (patch)
tree76e74807bc479502e13866b581b6bf86734ec634 /dev-python/pyotherside/pyotherside-1.5.8.ebuild
parent30d6f67c98d149508509d5e86f176d558793acc0 (diff)
gentoo resync : 13.10.2019
Diffstat (limited to 'dev-python/pyotherside/pyotherside-1.5.8.ebuild')
-rw-r--r--dev-python/pyotherside/pyotherside-1.5.8.ebuild41
1 files changed, 41 insertions, 0 deletions
diff --git a/dev-python/pyotherside/pyotherside-1.5.8.ebuild b/dev-python/pyotherside/pyotherside-1.5.8.ebuild
new file mode 100644
index 000000000000..38785447e3fb
--- /dev/null
+++ b/dev-python/pyotherside/pyotherside-1.5.8.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python3_{5,6,7} )
+
+inherit qmake-utils python-single-r1
+
+DESCRIPTION="Asynchronous Python 3 Bindings for Qt 5"
+HOMEPAGE="https://github.com/thp/pyotherside https://thp.io/2011/pyotherside/"
+SRC_URI="https://github.com/thp/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~amd64"
+REQUIRED_USE=${PYTHON_REQUIRED_USE}
+# Requires active X display
+RESTRICT="test"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-qt/qtcore:5
+ dev-qt/qtdeclarative:5
+ dev-qt/qtgui:5
+ dev-qt/qtsvg:5
+ "
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ sed -i -e "s/qtquicktests//" pyotherside.pro || die
+
+ default
+}
+
+src_configure() {
+ eqmake5
+}
+
+src_install() {
+ emake install INSTALL_ROOT="${D}"
+}