summaryrefslogtreecommitdiff
path: root/dev-python/pyopencl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/pyopencl
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pyopencl')
-rw-r--r--dev-python/pyopencl/Manifest6
-rw-r--r--dev-python/pyopencl/metadata.xml11
-rw-r--r--dev-python/pyopencl/pyopencl-2016.1.ebuild51
-rw-r--r--dev-python/pyopencl/pyopencl-2017.2.ebuild51
-rw-r--r--dev-python/pyopencl/pyopencl-9999.ebuild49
5 files changed, 168 insertions, 0 deletions
diff --git a/dev-python/pyopencl/Manifest b/dev-python/pyopencl/Manifest
new file mode 100644
index 000000000000..2e27b2cb7b6f
--- /dev/null
+++ b/dev-python/pyopencl/Manifest
@@ -0,0 +1,6 @@
+DIST pyopencl-2016.1.tar.gz 311327 BLAKE2B 6efb1e6cf6721e5ef606b572963938849b92c7348255be798a4af0604a798dc7804d839a46459275cf0720953deaa8ea6dc46aef594ac11fa61fa231681e2fa3 SHA512 3be8da315f9b4a4e03071152bb5968c5c7b102cbae6c70f358438cfd7951d12970a76dd8e922187ff73e47f7d0ce7a070e6f303dbe364c016796fa65d7e1de71
+DIST pyopencl-2017.2.tar.gz 350145 BLAKE2B 12c481893158f97dec612256b36e710ab52356c8b5f644f3710b5e34d4d10df3b27137ad76f29543fe16b3da725471e206aa5f69c646a79a65246d6091c686a9 SHA512 49f2ff619d8c214a3962b8444e68ba415dda032abaf9eeab259fcd1b21fbaab10bd057035161baef7f0182995834082218a6667464c01645231a94c88aa5c18b
+EBUILD pyopencl-2016.1.ebuild 1284 BLAKE2B f75d2be60618468510e131cb4ef83fae0e20398e4e226e3a9282fa47289d5e42144b380d9f1b2681e9fc2867c9890e6b098e13b52691314a42e1d6b914129931 SHA512 79ab69fd96ff42e44c840b7d6ba471fafeb9b45ef96e8237aaf6839959ae0cf389de277d822886e8e41a8a430152370c1ed5e73966b1dccc8e9753406ad07993
+EBUILD pyopencl-2017.2.ebuild 1288 BLAKE2B cac37c64586417abfeb62321534eed77ad7d835ccd58bc0b8d18a6e8b965d2246ce0f915af321e9389da5d3f070a8cc40867e89ec6f64bb48a212ef7cc55428b SHA512 792a3fc8ea30249a69cc137b03c26a94224df8bca93909986ee873b54382e109f884e897dd95695981e1efaae1e69c0ad51ec918e3ac35add306bbc4a4bbf470
+EBUILD pyopencl-9999.ebuild 1154 BLAKE2B 126fbd85640421297535efb213fc7fda6751a2b1a3ed64b26398155d033fe90b7f1538c32b27f54ca54aa28a51da9ea9f6e568b4964c9d741538af24b147c958 SHA512 fdaa6d5c0f1d303612d164bc3d4d2f61f4f958c1a2330c18cf8a8eda35ea6d28f52ebb16665eb03180012653a9aa9e46fc2e781437ab92ac757edbda62e1f63a
+MISC metadata.xml 311 BLAKE2B 4a843a4ed6ec77f0be47c898b7fc2a402f486d28dabd347983b1ab528e98173babd5f87270183812cf3d5f6cde6866e1a999e750e3dcdb1411d8b3f029eb10cb SHA512 14da0f2cb9db48698adc78e6827c161a93ac3307c0a595fbf69c45839dac9178966fa855193adf2f175685b7be31eb161c0281b3a35ef2e455db62f0ba65dde5
diff --git a/dev-python/pyopencl/metadata.xml b/dev-python/pyopencl/metadata.xml
new file mode 100644
index 000000000000..16b6e3efa20d
--- /dev/null
+++ b/dev-python/pyopencl/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">pyopencl</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pyopencl/pyopencl-2016.1.ebuild b/dev-python/pyopencl/pyopencl-2016.1.ebuild
new file mode 100644
index 000000000000..724896f127fa
--- /dev/null
+++ b/dev-python/pyopencl/pyopencl-2016.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python wrapper for OpenCL"
+HOMEPAGE="https://mathema.tician.de/software/pyopencl
+ https://pypi.org/project/pyopencl/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="examples opengl"
+
+RDEPEND="
+ >=dev-libs/boost-1.48[python,${PYTHON_USEDEP}]
+ >=dev-python/appdirs-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/cffi-1.1.0:=[${PYTHON_USEDEP}]
+ >=dev-python/decorator-3.2.0[${PYTHON_USEDEP}]
+ dev-python/mako[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ >=dev-python/pytools-2015.1.2[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=virtual/opencl-0-r1"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local myconf=()
+ if use opengl; then
+ myconf+=(--cl-enable-gl)
+ fi
+
+ "${PYTHON}" configure.py \
+ --boost-compiler=gcc \
+ --boost-python-libname=boost_python-${PYTHON_ABI}-mt \
+ --no-use-shipped-boost \
+ "${myconf[@]}"
+}
+
+python_install_all() {
+ if use examples; then
+ local EXAMPLES=( examples/. )
+ einfo "Some of the examples provided by this package require dev-python/matplotlib."
+ fi
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/pyopencl/pyopencl-2017.2.ebuild b/dev-python/pyopencl/pyopencl-2017.2.ebuild
new file mode 100644
index 000000000000..4c58f1356850
--- /dev/null
+++ b/dev-python/pyopencl/pyopencl-2017.2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python wrapper for OpenCL"
+HOMEPAGE="https://mathema.tician.de/software/pyopencl
+ https://pypi.org/project/pyopencl/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="examples opengl"
+
+RDEPEND="
+ >=dev-libs/boost-1.48[python,${PYTHON_USEDEP}]
+ >=dev-python/appdirs-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/cffi-1.1.0:=[${PYTHON_USEDEP}]
+ >=dev-python/decorator-3.2.0[${PYTHON_USEDEP}]
+ dev-python/mako[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ >=dev-python/pytools-2015.1.2[${PYTHON_USEDEP}]
+ >=dev-python/six-1.9.0[${PYTHON_USEDEP}]
+ >=virtual/opencl-0-r1"
+DEPEND="${RDEPEND}"
+
+src_configure() {
+ local myconf=()
+ if use opengl; then
+ myconf+=(--cl-enable-gl)
+ fi
+
+ "${PYTHON}" configure.py \
+ --boost-compiler=gcc \
+ --boost-python-libname=boost_python-${PYTHON_ABI}-mt \
+ --no-use-shipped-boost \
+ "${myconf[@]}"
+}
+
+python_install_all() {
+ if use examples; then
+ local EXAMPLES=( examples/. )
+ einfo "Some of the examples provided by this package require dev-python/matplotlib."
+ fi
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/pyopencl/pyopencl-9999.ebuild b/dev-python/pyopencl/pyopencl-9999.ebuild
new file mode 100644
index 000000000000..ef9432fac029
--- /dev/null
+++ b/dev-python/pyopencl/pyopencl-9999.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_4,3_5,3_6} )
+
+inherit distutils-r1 git-2
+
+EGIT_REPO_URI="https://git.tiker.net/trees/pyopencl.git"
+
+DESCRIPTION="Python wrapper for OpenCL"
+HOMEPAGE="https://mathema.tician.de/software/pyopencl
+ https://pypi.org/project/pyopencl/"
+SRC_URI=""
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS=""
+IUSE="examples opengl"
+
+RDEPEND=">=dev-libs/boost-1.48[python,${PYTHON_USEDEP}]
+ dev-python/decorator[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/mako[${PYTHON_USEDEP}]
+ >=dev-python/pytools-9999[${PYTHON_USEDEP}]
+ >=virtual/opencl-0-r1"
+DEPEND="${RDEPEND}"
+
+src_configure()
+{
+ local myconf=()
+ if use opengl; then
+ myconf+=(--cl-enable-gl)
+ fi
+
+ "${PYTHON}" configure.py \
+ --boost-compiler=gcc \
+ --boost-python-libname=boost_python-${PYTHON_ABI}-mt \
+ --no-use-shipped-boost \
+ "${myconf[@]}"
+}
+
+python_install_all() {
+ if use examples; then
+ local EXAMPLES=( examples/. )
+ einfo "Some of the examples provided by this package require dev-python/matplotlib."
+ fi
+ distutils-r1_python_install_all
+}