summaryrefslogtreecommitdiff
path: root/dev-python/pyopencl
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/pyopencl
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/pyopencl')
-rw-r--r--dev-python/pyopencl/Manifest2
-rw-r--r--dev-python/pyopencl/pyopencl-2022.1.5.ebuild57
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/pyopencl/Manifest b/dev-python/pyopencl/Manifest
index 56feab344aac..df75dd962e88 100644
--- a/dev-python/pyopencl/Manifest
+++ b/dev-python/pyopencl/Manifest
@@ -1,3 +1,5 @@
+DIST pyopencl-2022.1.5.tar.gz 454129 BLAKE2B 266bc327c9af5654287fc47cdf4e6002c7cddcd6f5e55bb70bb62aaee666dc5c102f78d4e946f010c1e109390c1d2e981e7ca6ca002d10f66248cb008b308734 SHA512 e6eb3e6d886d8ca1d94867a398b286556fd2d93535bb8481c7603cd521cd47606ce3d9cd6422830c6404305a4a1293234d8774fdda6923bdd2b4fc21fb39d377
DIST pyopencl-2022.1.tar.gz 452537 BLAKE2B 0d4d178a6bdf14dc3769dcb78c42bc894c0a443a6811fe9b25dedbc4a43debc06d1a1c32cb2a0df06fe16d1b2e78e65ef4f3ca8e9931be39384b3c8c813336de SHA512 e873807e757c19b59dbac2a0522fbb9c6e8af955d62bdcf06d8f3d792db3c9d2ce15372a6eefdca5b3f6756c35a85b5ff8d7dc1b6449bfd12c2b588576dd6f24
+EBUILD pyopencl-2022.1.5.ebuild 1526 BLAKE2B 9b68731abc39755ed821c519b707266dbcd70894d42e08b25a469eb7890e0bda52b0f2b903a52215aa0e2c58951e1c7c54f87b95be1c54aa0a6b0c86f67c9a91 SHA512 eb2efe2fb5d0ca6b85204e55256ba7f6eca721d68b96eeb421f465f1bff4332a10c587f3fe71d5dd72d2e5812f1c9ee4449432464f73d7cbeaca48c10d807124
EBUILD pyopencl-2022.1.ebuild 1520 BLAKE2B 5ff0a66be8d8d323038a93879aaf5a00d8559a4271c7c1ecb3b7ce484b5b33b00ec6fd860f4ce0af533b690cea87c74ffb8f6e4b4b9c6840bbbc72c82a19a016 SHA512 e5257aa3af1faa3ab801b1765b25175f45baec990c3033243a71d3ac36908fc2d1bdb24f34d33163f59636cc5d7bab7399fad4e5eeb6f13ffb3891036452bacc
MISC metadata.xml 317 BLAKE2B ba532c522d5fd599dfd41180c9813f8124dc64cd3bc7a3a7b1ecdc121b216db4b43f6cae9c32c52a430fbf6e9a22c0cf27ffaf0041ca372d81666991bcf0e979 SHA512 845a8b83a5d7729ea0fca8b704de297b8b8c0d8f315fad0bea7c0c645bc79dd993209e9ca5e89ec9c8ddbe6db2b1f142c3e1f7e5b8e4b6259fe927527ce6a919
diff --git a/dev-python/pyopencl/pyopencl-2022.1.5.ebuild b/dev-python/pyopencl/pyopencl-2022.1.5.ebuild
new file mode 100644
index 000000000000..dc2cb443735e
--- /dev/null
+++ b/dev-python/pyopencl/pyopencl-2022.1.5.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+DISTUTILS_USE_PEP517=setuptools
+
+inherit distutils-r1
+
+DESCRIPTION="Python wrapper for OpenCL"
+HOMEPAGE="https://mathema.tician.de/software/pyopencl/
+ https://pypi.org/project/pyopencl/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="examples opengl"
+
+DEPEND=">=virtual/opencl-2"
+RDEPEND="${DEPEND}
+ >=dev-python/mako-0.3.6[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ >=dev-python/platformdirs-2.2.0[${PYTHON_USEDEP}]
+ >=dev-python/pytools-2021.2.7[${PYTHON_USEDEP}]"
+# libglvnd is only needed for the headers
+BDEPEND="dev-python/numpy[${PYTHON_USEDEP}]
+ >=dev-python/pybind11-2.5.0[${PYTHON_USEDEP}]
+ opengl? ( media-libs/libglvnd )"
+
+# The test suite fails if there are no OpenCL platforms available, and
+# even if there is one (which requires the presence of both an OpenCL
+# runtime *and* hardware supported by it - simply emerging any runtime
+# is not enough) the vast majority of tests end up skipped because by
+# default the portage user hasn't got sufficient privileges to talk
+# to the GPU.
+RESTRICT="test"
+
+python_configure_all() {
+ local myconf=()
+ if use opengl; then
+ myconf+=(--cl-enable-gl)
+ fi
+
+ "${EPYTHON}" configure.py \
+ "${myconf[@]}"
+}
+
+python_install_all() {
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ distutils-r1_python_install_all
+}