summaryrefslogtreecommitdiff
path: root/dev-python/pyopencl/pyopencl-2022.1.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-28 03:03:20 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-28 03:03:20 +0100
commit0b1f53c54388382ff701d00d3f5eb981ed040f2a (patch)
treeec5c4665c03dbae83c878cb536837e611a8584a6 /dev-python/pyopencl/pyopencl-2022.1.6.ebuild
parent59fb67b05708a525b33b4a84de896b3b1ae34012 (diff)
gentoo auto-resync : 28:07:2022 - 03:03:20
Diffstat (limited to 'dev-python/pyopencl/pyopencl-2022.1.6.ebuild')
-rw-r--r--dev-python/pyopencl/pyopencl-2022.1.6.ebuild10
1 files changed, 6 insertions, 4 deletions
diff --git a/dev-python/pyopencl/pyopencl-2022.1.6.ebuild b/dev-python/pyopencl/pyopencl-2022.1.6.ebuild
index aaaad732504f..19e2c5a987c8 100644
--- a/dev-python/pyopencl/pyopencl-2022.1.6.ebuild
+++ b/dev-python/pyopencl/pyopencl-2022.1.6.ebuild
@@ -18,16 +18,18 @@ SLOT="0"
KEYWORDS="~amd64 ~ppc64"
IUSE="examples opengl"
-DEPEND=">=virtual/opencl-2"
-RDEPEND="${DEPEND}
+COMMON=">=virtual/opencl-2"
+# libglvnd is only needed for the headers
+DEPEND="${COMMON}
+ opengl? ( media-libs/libglvnd )"
+RDEPEND="${COMMON}
>=dev-python/mako-0.3.6[${PYTHON_USEDEP}]
dev-python/numpy[${PYTHON_USEDEP}]
>=dev-python/platformdirs-2.2.0[${PYTHON_USEDEP}]
>=dev-python/pytools-2021.2.7[${PYTHON_USEDEP}]"
-# libglvnd is only needed for the headers
BDEPEND="dev-python/numpy[${PYTHON_USEDEP}]
>=dev-python/pybind11-2.5.0[${PYTHON_USEDEP}]
- opengl? ( media-libs/libglvnd )"
+ <dev-python/pybind11-2.10.0[${PYTHON_USEDEP}]"
# The test suite fails if there are no OpenCL platforms available, and
# even if there is one (which requires the presence of both an OpenCL