summaryrefslogtreecommitdiff
path: root/dev-python/pyocr/pyocr-0.5.3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-09-21 18:00:10 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-09-21 18:00:10 +0100
commit265dbe5dbc14c199299496c6db8fce3f76647015 (patch)
treeab18b5617d138f6684566b619405090989d55a2c /dev-python/pyocr/pyocr-0.5.3.ebuild
parent586819755b4dbfdffdc8a725ab7c0f86095b8489 (diff)
gentoo resync : 21.09.2018
Diffstat (limited to 'dev-python/pyocr/pyocr-0.5.3.ebuild')
-rw-r--r--dev-python/pyocr/pyocr-0.5.3.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/pyocr/pyocr-0.5.3.ebuild b/dev-python/pyocr/pyocr-0.5.3.ebuild
new file mode 100644
index 000000000000..f08810e858da
--- /dev/null
+++ b/dev-python/pyocr/pyocr-0.5.3.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python2_7 python3_{5,6,7} )
+
+inherit distutils-r1
+
+DESCRIPTION="An optical character recognition (OCR) tool wrapper for python"
+HOMEPAGE="https://github.com/openpaperwork/pyocr"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+IUSE="cuneiform +tesseract"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="cuneiform? ( app-text/cuneiform )
+ tesseract? ( app-text/tesseract )
+ dev-python/pillow
+ dev-python/six"
+DEPEND="${RDEPEND}"
+
+REQUIRED_USE="|| ( cuneiform tesseract )"
+
+RESTRICT="test" # reguires tesseract[l10n_fr,l10n_en,l10n_jp]