summaryrefslogtreecommitdiff
path: root/dev-python/pynest2d
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
commit6abbf81ef2f298e3221ff5e67a1f3c5f23958212 (patch)
tree25413d1cb3a0cbfe36029db32398c0f333609215 /dev-python/pynest2d
parent9c417bacd51da6d8b57fa9f37425161d30d4b95b (diff)
gentoo resync : 14.12.2020
Diffstat (limited to 'dev-python/pynest2d')
-rw-r--r--dev-python/pynest2d/Manifest4
-rw-r--r--dev-python/pynest2d/files/pynest2d-4.8.0-required-flags-from-Libnest2D-target.patch24
-rw-r--r--dev-python/pynest2d/metadata.xml11
-rw-r--r--dev-python/pynest2d/pynest2d-4.8.0.ebuild39
4 files changed, 78 insertions, 0 deletions
diff --git a/dev-python/pynest2d/Manifest b/dev-python/pynest2d/Manifest
new file mode 100644
index 000000000000..12446226b206
--- /dev/null
+++ b/dev-python/pynest2d/Manifest
@@ -0,0 +1,4 @@
+AUX pynest2d-4.8.0-required-flags-from-Libnest2D-target.patch 1422 BLAKE2B b42ac90f1182e38d31e9dac877d8e94baa01db734dc31381d674f000a9982ed65f316c4613f0cfcc1910ec086c3e3bf51cb08d4d72624fc684ec658a8260f8f4 SHA512 2957da641a52a457254bf53a83a7f83085306f2158ca814feeeee6a230c4d6b9bafb29dd0aeb7244857a4152fdb927fa02085d2a19b77b8f990128491a051ce6
+DIST pynest2d-4.8.0.tar.gz 18174 BLAKE2B 3720815b3d5ba5d4a0dd24ec4104af318d2d7f2e86e66ada68ead8249ed28184d9a153995f143cc4e00d603804da959a086a27decfe2b1e0ef00256a891e0d17 SHA512 1304450f94589b5212f11d83fb228f0deb919698b44b1651f248105c23b65cf3d233e67526bbfb47df74b9b18d0c465f4188d02a0a6941564b551f50d9a3c84f
+EBUILD pynest2d-4.8.0.ebuild 892 BLAKE2B 513a0f81ba0de1a72550f19f8e521269f1c8fa162161006b6e6351133e0cb2f2aa6694a23a184c193ca24e924cf5a48160cc5ccd36b6ee55a14cf81888184b63 SHA512 0beb2834dea7c184953f9368fa1073c4ac3882b0437a673a5136697767bffdfa3fceeab2fefd435a47b9c65aade2e7fec2ce6b7c999a73310ff411c682292bf3
+MISC metadata.xml 343 BLAKE2B 928ff1dd477a69f0e796bcebe542313551f1ce8513714d62fcf3d4d929e9a5fb555bc74e7a613ea7b4e2b4affe87dcb03f2a44d4ebb042e25d4e26caf510eae1 SHA512 e494a21cde8c8d11c72a4c9705e5e841dad900ab00966718a397ac9d95e06e926621736ae609ff4b1ab9448c4830e07e0542b295c0d288a07864db44d5808485
diff --git a/dev-python/pynest2d/files/pynest2d-4.8.0-required-flags-from-Libnest2D-target.patch b/dev-python/pynest2d/files/pynest2d-4.8.0-required-flags-from-Libnest2D-target.patch
new file mode 100644
index 000000000000..c2c9452756fb
--- /dev/null
+++ b/dev-python/pynest2d/files/pynest2d-4.8.0-required-flags-from-Libnest2D-target.patch
@@ -0,0 +1,24 @@
+See https://github.com/Ultimaker/pynest2d/pull/3
+--- a/CMakeLists.txt
++++ b/CMakeLists.txt
+@@ -10,11 +10,7 @@ list(APPEND CMAKE_MODULE_PATH "${CMAKE_SOURCE_DIR}/cmake")
+ find_package(PythonInterp 3.5 REQUIRED) # Dependency of SIP.
+ find_package(PythonLibs 3.5 REQUIRED) # Dependency of SIP.
+ find_package(SIP REQUIRED) # To create Python bindings.
+-find_package(libnest2d REQUIRED) # The library we're creating bindings for.
+-find_package(Clipper REQUIRED) # Dependency of libnest2d.
+-find_package(NLopt REQUIRED) # Dependency of libnest2d.
+-find_package(Boost REQUIRED) # Dependency of libnest2d.
+-set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -DLIBNEST2D_GEOMETRIES_clipper -DLIBNEST2D_OPTIMIZERS_nlopt -DLIBNEST2D_THREADING_std") # Tell libnest2d to use Clipper and NLopt, and standard threads.
++find_package(Libnest2D REQUIRED) # The library we're creating bindings for.
+
+ # Some build options.
+ set(CMAKE_CXX_STANDARD 11)
+@@ -45,5 +41,5 @@ set(SIP_EXTRA_FILES_DEPEND
+ )
+
+ set(SIP_EXTRA_OPTIONS -g) # Always release the GIL before calling C++ methods.
+-include_directories(src/ ${SIP_INCLUDE_DIRS} ${Python3_INCLUDE_DIRS} ${CLIPPER_INCLUDE_DIRS} ${NLopt_INCLUDE_DIRS} ${LIBNEST2D_INCLUDE_DIRS})
+-add_sip_python_module(pynest2d src/Pynest2D.sip ${CLIPPER_LIBRARIES} ${NLopt_LIBRARIES})
++include_directories(src/ ${SIP_INCLUDE_DIRS})
++add_sip_python_module(pynest2d src/Pynest2D.sip Libnest2D::libnest2d_headeronly)
diff --git a/dev-python/pynest2d/metadata.xml b/dev-python/pynest2d/metadata.xml
new file mode 100644
index 000000000000..52add8ef7465
--- /dev/null
+++ b/dev-python/pynest2d/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>3dprint@gentoo.org</email>
+ <name>Gentoo 3D Printer Project</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">Ultimaker/pynest2d</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pynest2d/pynest2d-4.8.0.ebuild b/dev-python/pynest2d/pynest2d-4.8.0.ebuild
new file mode 100644
index 000000000000..5f57d42dca50
--- /dev/null
+++ b/dev-python/pynest2d/pynest2d-4.8.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8} )
+
+inherit cmake python-single-r1
+
+DESCRIPTION="Python bindings for libnest2d"
+HOMEPAGE="https://github.com/Ultimaker/pynest2d"
+SRC_URI="https://github.com/Ultimaker/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="LGPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~x86"
+
+IUSE=""
+
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="${PYTHON_DEPS}
+ dev-libs/libnest2d
+ $(python_gen_cond_dep 'dev-python/sip[${PYTHON_MULTI_USEDEP}]')
+ "
+
+DEPEND="${RDEPEND}"
+
+PATCHES=( "${FILESDIR}/${P}-required-flags-from-Libnest2D-target.patch" )
+
+# test? ( )
+# ""
+
+#DEPENDENCIES
+
+# Clipper, a polygon clipping library.
+# NLopt, a library to solve non-linear optimization problems.
+# Boost, the headers only.
+# Sip, an application to generate Python bindings more easily.