summaryrefslogtreecommitdiff
path: root/dev-python/pynest2d/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
committerV3n3RiX <venerix@koprulu.sector>2022-05-12 16:42:50 +0300
commit752d6256e5204b958b0ef7905675a940b5e9172f (patch)
tree330d16e6362a49cbed8875a777fe641a43376cd3 /dev-python/pynest2d/files
parent0c100b7dd2b30e75b799d806df4ef899fd98e1ea (diff)
gentoo resync : 12.05.2022
Diffstat (limited to 'dev-python/pynest2d/files')
-rw-r--r--dev-python/pynest2d/files/pynest2d-4.8.0-fix-cpp-version.patch11
-rw-r--r--dev-python/pynest2d/files/pynest2d-4.8.0-required-flags-from-Libnest2D-target.patch24
2 files changed, 0 insertions, 35 deletions
diff --git a/dev-python/pynest2d/files/pynest2d-4.8.0-fix-cpp-version.patch b/dev-python/pynest2d/files/pynest2d-4.8.0-fix-cpp-version.patch
deleted file mode 100644
index 1fe895892de2..000000000000
--- a/dev-python/pynest2d/files/pynest2d-4.8.0-fix-cpp-version.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -17,7 +17,7 @@ find_package(Boost REQUIRED) # Dependency of libnest2d.
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -DLIBNEST2D_GEOMETRIES_clipper -DLIBNEST2D_OPTIMIZERS_nlopt -DLIBNEST2D_THREADING_std") # Tell libnest2d to use Clipper and NLopt, and standard threads.
-
- # Some build options.
--set(CMAKE_CXX_STANDARD 11)
-+set(CMAKE_CXX_STANDARD 14)
- if(APPLE AND CMAKE_CXX_COMPILER_ID MATCHES "Clang")
- set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -stdlib=libc++")
- endif()
diff --git a/dev-python/pynest2d/files/pynest2d-4.8.0-required-flags-from-Libnest2D-target.patch b/dev-python/pynest2d/files/pynest2d-4.8.0-required-flags-from-Libnest2D-target.patch
deleted file mode 100644
index c2c9452756fb..000000000000
--- a/dev-python/pynest2d/files/pynest2d-4.8.0-required-flags-from-Libnest2D-target.patch
+++ /dev/null
@@ -1,24 +0,0 @@
-See https://github.com/Ultimaker/pynest2d/pull/3
---- a/CMakeLists.txt
-+++ b/CMakeLists.txt
-@@ -10,11 +10,7 @@ list(APPEND CMAKE_MODULE_PATH "${CMAKE_SOURCE_DIR}/cmake")
- find_package(PythonInterp 3.5 REQUIRED) # Dependency of SIP.
- find_package(PythonLibs 3.5 REQUIRED) # Dependency of SIP.
- find_package(SIP REQUIRED) # To create Python bindings.
--find_package(libnest2d REQUIRED) # The library we're creating bindings for.
--find_package(Clipper REQUIRED) # Dependency of libnest2d.
--find_package(NLopt REQUIRED) # Dependency of libnest2d.
--find_package(Boost REQUIRED) # Dependency of libnest2d.
--set(CMAKE_CXX_FLAGS "${CMAKE_CXX_FLAGS} -DLIBNEST2D_GEOMETRIES_clipper -DLIBNEST2D_OPTIMIZERS_nlopt -DLIBNEST2D_THREADING_std") # Tell libnest2d to use Clipper and NLopt, and standard threads.
-+find_package(Libnest2D REQUIRED) # The library we're creating bindings for.
-
- # Some build options.
- set(CMAKE_CXX_STANDARD 11)
-@@ -45,5 +41,5 @@ set(SIP_EXTRA_FILES_DEPEND
- )
-
- set(SIP_EXTRA_OPTIONS -g) # Always release the GIL before calling C++ methods.
--include_directories(src/ ${SIP_INCLUDE_DIRS} ${Python3_INCLUDE_DIRS} ${CLIPPER_INCLUDE_DIRS} ${NLopt_INCLUDE_DIRS} ${LIBNEST2D_INCLUDE_DIRS})
--add_sip_python_module(pynest2d src/Pynest2D.sip ${CLIPPER_LIBRARIES} ${NLopt_LIBRARIES})
-+include_directories(src/ ${SIP_INCLUDE_DIRS})
-+add_sip_python_module(pynest2d src/Pynest2D.sip Libnest2D::libnest2d_headeronly)