summaryrefslogtreecommitdiff
path: root/dev-python/pympler
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-12-25 23:06:25 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-12-25 23:06:25 +0000
commit441d1370330332b7d78f238d2f5e13f7aed5e4e0 (patch)
tree6a5171dd615dfeee62a45044144c66e864738fb0 /dev-python/pympler
parentab3da91fb6c91a9df52fff8f991570f456fd3c7a (diff)
gentoo christmass resync : 25.12.2020
Diffstat (limited to 'dev-python/pympler')
-rw-r--r--dev-python/pympler/Manifest3
-rw-r--r--dev-python/pympler/metadata.xml20
-rw-r--r--dev-python/pympler/pympler-0.6.ebuild44
3 files changed, 0 insertions, 67 deletions
diff --git a/dev-python/pympler/Manifest b/dev-python/pympler/Manifest
deleted file mode 100644
index 2a0944c5bf38..000000000000
--- a/dev-python/pympler/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST pympler-0.6.tar.gz 267267 BLAKE2B 84a8df3177d0defed949869bec9342beb4336c912be5539c597388207abcbc53fa5218da34b16a872dca804ff559a448dc092b4d33396d570164311c1808765a SHA512 891822ce0a76377d74aa99dd2ce8b21a364084f0bc03ab6d6fe505597a0e182dde459b218dff8e0e6a753e1d88ba9f01b3a4b97be31a20e73a93d6c6fee66e1b
-EBUILD pympler-0.6.ebuild 1072 BLAKE2B 8b2cde7bb8688af5aa899667df1715e50a2e67868e4688411c0e7158dbd4e7c1ff39359ef7656b514a20ff1128e7f76e8dfdd57404bd4ca7108baef64b958fae SHA512 776fc4055e59624bcade8337da1b47743d8f0dc1d932753ecd324167972bb822ca98ae0632c07bb52ff5936960dcaea5013a79a298a50f85e9fc7bda1177ea5a
-MISC metadata.xml 800 BLAKE2B 7fafff914239dfdca3d757a3600f81021b5039df9dd74e7085ad1016caa0a83f6d21be3f565d2bfaa9d162218194f0073975eccb781b93731762883913572d5f SHA512 6f0fa3b2071c5ec3e4d3ad63473e4aacb98673f880422f4b4d5680a3c321714bb9e5f637fa913696bb5e738667829bdfe7b871140d6e1fa48cee725980954878
diff --git a/dev-python/pympler/metadata.xml b/dev-python/pympler/metadata.xml
deleted file mode 100644
index a403ca47e620..000000000000
--- a/dev-python/pympler/metadata.xml
+++ /dev/null
@@ -1,20 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>python@gentoo.org</email>
- <name>Python</name>
- </maintainer>
- <longdescription>
-Pympler is a development tool to measure, monitor and analyze the memory
-behavior of Python objects in a running Python application. By pympling a
-Python application, detailed insight in the size and the lifetime of Python
-objects can be obtained. Undesirable or unexpected runtime behavior like
-memory bloat and other "pymples" can easily be identified.
-</longdescription>
- <stabilize-allarches/>
- <upstream>
- <remote-id type="pypi">Pympler</remote-id>
- <remote-id type="github">pympler/pympler</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-python/pympler/pympler-0.6.ebuild b/dev-python/pympler/pympler-0.6.ebuild
deleted file mode 100644
index abcf53a18502..000000000000
--- a/dev-python/pympler/pympler-0.6.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DISTUTILS_USE_SETUPTOOLS=no
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit distutils-r1
-
-MY_PN="Pympler"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Memory profiling for Python applications"
-HOMEPAGE="https://pypi.org/project/Pympler/ https://github.com/pympler/pympler"
-SRC_URI="https://github.com/pympler/pympler/archive/${PV}.tar.gz -> ${P}.tar.gz"
-# The PyPi tarball is missing the documentation
-#SRC_URI="mirror://pypi/P/${MY_PN}/${MY_P}.tar.gz"
-
-SLOT="0"
-LICENSE="Apache-2.0"
-KEYWORDS="~alpha amd64 arm ~ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux"
-IUSE="doc test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="dev-python/bottle[${PYTHON_USEDEP}]"
-DEPEND="doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( ${RDEPEND} )"
-
-python_compile_all() {
- if use doc; then
- python_setup
- sphinx-build -b html doc/{source,html} || die
- fi
-}
-
-python_test() {
- esetup.py try
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( doc/html/. )
- distutils-r1_python_install_all
-}