summaryrefslogtreecommitdiff
path: root/dev-python/pympler
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 20:57:42 +0100
commit1798c4aeca70ac8d0a243684d6a798fbc65735f8 (patch)
treee48e19cb6fa03de18e1c63e1a93371b7ebc4eb56 /dev-python/pympler
parentd87262dd706fec50cd150aab3e93883b6337466d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pympler')
-rw-r--r--dev-python/pympler/Manifest3
-rw-r--r--dev-python/pympler/metadata.xml19
-rw-r--r--dev-python/pympler/pympler-0.5.ebuild42
3 files changed, 0 insertions, 64 deletions
diff --git a/dev-python/pympler/Manifest b/dev-python/pympler/Manifest
deleted file mode 100644
index 4e6891ba7681..000000000000
--- a/dev-python/pympler/Manifest
+++ /dev/null
@@ -1,3 +0,0 @@
-DIST pympler-0.5.tar.gz 263627 BLAKE2B 5ce881664e2d57d1a7a9b87238cfc6657fd35a140e6ab906b55ca6e0ac91fc8a74377d4db21706708c55773f8ca65d3578c101669ba409339418e09ca53d0fb2 SHA512 254b758df70bafe57f315a973de0caeef6cd616bd0cc7b4475c74c3a9a94f52b3ac3da3f073483db3560cd0060536c95ed1297007c24dfe8db89fd893ff1409c
-EBUILD pympler-0.5.ebuild 1030 BLAKE2B 14da7bb233d40ef678276520347c567a226a9e71498834020ace97a08fdb292c03a725c7e307a407ce92ba493a29f1a1239120f12a90c41dfaaeb27d6289ea36 SHA512 25e9285a5702ba56217263ea586a118285f9eb2fb68c3976308a454a95a84999ddf2f9c3ab3417cf06d8f571ab9f81ec822a8846ab1ff4b84d239b7e1efc55d6
-MISC metadata.xml 775 BLAKE2B bb415e7f09dec344f5f97fac36d3659c0670de5230a628515f26b1b9177883b6d99bed0ad2992af116f6b800a9f73aac3f436a6480a57c6ea5565e01f56c95b5 SHA512 e97ef9decf71b8f941e1fb54fee0aef66dee9c3e722f590d1d08f87dc20ba709713089c91891f0c686d69053321894fd6c8e6de690154f193e2bb72a5d879d41
diff --git a/dev-python/pympler/metadata.xml b/dev-python/pympler/metadata.xml
deleted file mode 100644
index b7d64a47521f..000000000000
--- a/dev-python/pympler/metadata.xml
+++ /dev/null
@@ -1,19 +0,0 @@
-<?xml version="1.0" encoding="UTF-8"?>
-<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
-<pkgmetadata>
- <maintainer type="project">
- <email>python@gentoo.org</email>
- <name>Python</name>
- </maintainer>
- <longdescription>
-Pympler is a development tool to measure, monitor and analyze the memory
-behavior of Python objects in a running Python application. By pympling a
-Python application, detailed insight in the size and the lifetime of Python
-objects can be obtained. Undesirable or unexpected runtime behavior like
-memory bloat and other "pymples" can easily be identified.
-</longdescription>
- <upstream>
- <remote-id type="pypi">Pympler</remote-id>
- <remote-id type="github">pympler/pympler</remote-id>
- </upstream>
-</pkgmetadata>
diff --git a/dev-python/pympler/pympler-0.5.ebuild b/dev-python/pympler/pympler-0.5.ebuild
deleted file mode 100644
index 37d0a8d9a12d..000000000000
--- a/dev-python/pympler/pympler-0.5.ebuild
+++ /dev/null
@@ -1,42 +0,0 @@
-# Copyright 1999-2018 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
-
-inherit distutils-r1
-
-MY_PN="Pympler"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Memory profiling for Python applications"
-HOMEPAGE="https://pypi.org/project/Pympler/ https://github.com/pympler/pympler"
-SRC_URI="https://github.com/pympler/pympler/archive/${PV}.tar.gz -> ${P}.tar.gz"
-# The PyPi tarball is missing the documentation
-#SRC_URI="mirror://pypi/P/${MY_PN}/${MY_P}.tar.gz"
-
-SLOT="0"
-LICENSE="Apache-2.0"
-KEYWORDS="alpha amd64 arm ia64 ppc ppc64 sparc x86 ~amd64-linux ~x86-linux"
-IUSE="doc test"
-
-RDEPEND="dev-python/bottle[${PYTHON_USEDEP}]"
-DEPEND="doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? ( ${RDEPEND} )"
-
-python_compile_all() {
- if use doc; then
- python_setup
- sphinx-build -b html doc/{source,html} || die
- fi
-}
-
-python_test() {
- esetup.py try
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( doc/html/. )
- distutils-r1_python_install_all
-}