summaryrefslogtreecommitdiff
path: root/dev-python/pymongo
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
committerV3n3RiX <venerix@redcorelinux.org>2020-12-14 13:26:14 +0000
commit6abbf81ef2f298e3221ff5e67a1f3c5f23958212 (patch)
tree25413d1cb3a0cbfe36029db32398c0f333609215 /dev-python/pymongo
parent9c417bacd51da6d8b57fa9f37425161d30d4b95b (diff)
gentoo resync : 14.12.2020
Diffstat (limited to 'dev-python/pymongo')
-rw-r--r--dev-python/pymongo/Manifest2
-rw-r--r--dev-python/pymongo/pymongo-3.11.2.ebuild116
2 files changed, 118 insertions, 0 deletions
diff --git a/dev-python/pymongo/Manifest b/dev-python/pymongo/Manifest
index e60e33bcbaf3..68b79ea0de8d 100644
--- a/dev-python/pymongo/Manifest
+++ b/dev-python/pymongo/Manifest
@@ -1,5 +1,7 @@
DIST mongo-python-driver-3.11.1.tar.gz 981098 BLAKE2B 27c24a16fe685dda728eadee7784596178ef8ca50d4017bd38ec1bd5ffb29a6eb2e2b24db82cb7d1fe545c58575b3e83d54bfda645eb6dca0d4678e59f7d201b SHA512 459218ae2b4783dc1ec0fb63be62f38c138bc074b6685e3785840b7ed38472a579ba3bd92ceee3a27757b38975963911dab3235f0eba1cc261e083d8e020f462
+DIST mongo-python-driver-3.11.2.tar.gz 982527 BLAKE2B 3dcbf57a1cb0a09f9747c1a4770f4935b1c5f524f14392a3a1ce2ee6d3c6f72dc08d96d81300dd7bf7fcd7e5eeb0d6d8af7ac8240f41b460952046d30e8fa3a5 SHA512 110be1c6301f0f5511ed0d8a0cccc1e79c4a1a217bef486afebd2238522735d1e0e2a930533d05194aa485db65c4555bd46dbcf5808a33b2b07bc907055f2b7e
DIST pymongo-3.11.0.tar.gz 771691 BLAKE2B 5ae5b78caac335656c1005666c5633882da517c512bbfdb0df2c4569ec5060fa9623a23f48ffcf0c6ab2cdc69f6534f36ef18c929047bbb22cfbe9055a0881b7 SHA512 4f8a185013cbb3c07774d3c6aecc9e97dabb4ba55176fa8a51e17bcdb7cbbebaacd16304e580b4c6aeb26aad964401249313b59dde3c5c248c4496d64d18b22c
EBUILD pymongo-3.11.0-r1.ebuild 2642 BLAKE2B a7f5f89387c694c125b20859f8b494d34e2eba8b197b14c0533e87635024e615ada3ec7408b092d4ab105a50f17a8b150e1dcd72b1118fb4fe21256647aadeda SHA512 819b922f0f6d55730a5a630fa66ea6fe42c321e8c850539b0d5a228d32d50c75e50500476534663930c85cb2c7305792dee94d05ea6754f1fc950a30d98ff3c5
EBUILD pymongo-3.11.1.ebuild 2745 BLAKE2B 29f5f2c188f1f8deebe0f7ac55826c532eb25fe2ae82095609fc24a9af6873e49d92f1d10a6a4fb971eeb936436ad3eb059fe998f97b88581184c7bf57340803 SHA512 da84a037623e708d3fdbfc1ae3d815764281ab8956c08ee2d4970b5e023b4f94bbfc91fd9ba49bc294919ca0e4374cfc806ec893eb305c1877cb57938d8840d8
+EBUILD pymongo-3.11.2.ebuild 2745 BLAKE2B 29f5f2c188f1f8deebe0f7ac55826c532eb25fe2ae82095609fc24a9af6873e49d92f1d10a6a4fb971eeb936436ad3eb059fe998f97b88581184c7bf57340803 SHA512 da84a037623e708d3fdbfc1ae3d815764281ab8956c08ee2d4970b5e023b4f94bbfc91fd9ba49bc294919ca0e4374cfc806ec893eb305c1877cb57938d8840d8
MISC metadata.xml 672 BLAKE2B 48cf6ce2f03ec2865a99fd033455a1b0a53cf9e55240ab6e993483929a6dd93661afcea7fa255095b66536f0a8cc05b5c4e6a12bd044547a5cf190559a9e480f SHA512 89b8a3551a5b0bd495bc98ac2f9324daeb3f3d81d0f6b991e5537e02c7b369201f9692be5acbe228ddcd3581002a39ac777ea5fc136957e9ccb9683f205e38ea
diff --git a/dev-python/pymongo/pymongo-3.11.2.ebuild b/dev-python/pymongo/pymongo-3.11.2.ebuild
new file mode 100644
index 000000000000..0327e9903e41
--- /dev/null
+++ b/dev-python/pymongo/pymongo-3.11.2.ebuild
@@ -0,0 +1,116 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+inherit check-reqs distutils-r1
+
+MY_P=mongo-python-driver-${PV}
+DESCRIPTION="Python driver for MongoDB"
+HOMEPAGE="https://github.com/mongodb/mongo-python-driver https://pypi.org/project/pymongo/"
+SRC_URI="
+ https://github.com/mongodb/mongo-python-driver/archive/${PV}.tar.gz
+ -> ${MY_P}.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~hppa ~x86"
+IUSE="doc kerberos test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ kerberos? ( dev-python/pykerberos[${PYTHON_USEDEP}] )
+"
+BDEPEND="
+ test? (
+ >=dev-db/mongodb-2.6.0
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+"
+DISTUTILS_IN_SOURCE_BUILD=1
+
+distutils_enable_sphinx doc
+
+reqcheck() {
+ if use test; then
+ # During the tests, database size reaches 1.5G.
+ local CHECKREQS_DISK_BUILD=1536M
+
+ check-reqs_${1}
+ fi
+}
+
+pkg_pretend() {
+ reqcheck pkg_pretend
+}
+
+pkg_setup() {
+ reqcheck pkg_setup
+}
+
+src_prepare() {
+ # network-sandbox probably
+ rm test/test_srv_polling.py || die
+ sed -e 's:test_connection_timeout_ms_propagates_to_DNS_resolver:_&:' \
+ -i test/test_client.py || die
+ # relies on exact exception message
+ sed -e 's:abstract methods:abstract:' \
+ -i test/test_custom_types.py || die
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ # Yes, we need TCP/IP for that...
+ local DB_IP=127.0.0.1
+ local DB_PORT=27000
+
+ export DB_IP DB_PORT
+
+ local dbpath=${TMPDIR}/mongo.db
+ local logpath=${TMPDIR}/mongod.log
+
+ # Now, the hard part: we need to find a free port for mongod.
+ # We're just trying to run it random port numbers and check the log
+ # for bind errors. It shall be noted that 'mongod --fork' does not
+ # return failure when it fails to bind.
+
+ mkdir -p "${dbpath}" || die
+ while true; do
+ ebegin "Trying to start mongod on port ${DB_PORT}"
+
+ LC_ALL=C \
+ mongod --dbpath "${dbpath}" --nojournal \
+ --bind_ip ${DB_IP} --port ${DB_PORT} \
+ --unixSocketPrefix "${TMPDIR}" \
+ --logpath "${logpath}" --fork \
+ && sleep 2
+
+ # Now we need to check if the server actually started...
+ if [[ ${?} -eq 0 && -S "${TMPDIR}"/mongodb-${DB_PORT}.sock ]]; then
+ # yay!
+ eend 0
+ break
+ elif grep -q 'Address already in use' "${logpath}"; then
+ # ay, someone took our port!
+ eend 1
+ : $(( DB_PORT += 1 ))
+ continue
+ else
+ eend 1
+ eerror "Unable to start mongod for tests. See the server log:"
+ eerror " ${logpath}"
+ die "Unable to start mongod for tests."
+ fi
+ done
+
+ local failed
+ DB_PORT2=$(( DB_PORT + 1 )) DB_PORT3=$(( DB_PORT + 2 )) esetup.py test || failed=1
+
+ mongod --dbpath "${dbpath}" --shutdown || die
+
+ [[ ${failed} ]] && die "Tests fail with ${EPYTHON}"
+
+ rm -rf "${dbpath}" || die
+}