summaryrefslogtreecommitdiff
path: root/dev-python/pymdown-lexers/pymdown-lexers-0_pre20210902.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/pymdown-lexers/pymdown-lexers-0_pre20210902.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/pymdown-lexers/pymdown-lexers-0_pre20210902.ebuild')
-rw-r--r--dev-python/pymdown-lexers/pymdown-lexers-0_pre20210902.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/dev-python/pymdown-lexers/pymdown-lexers-0_pre20210902.ebuild b/dev-python/pymdown-lexers/pymdown-lexers-0_pre20210902.ebuild
new file mode 100644
index 000000000000..150d59192a6b
--- /dev/null
+++ b/dev-python/pymdown-lexers/pymdown-lexers-0_pre20210902.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+DISTUTILS_USE_PEP517=setuptools
+inherit distutils-r1
+
+COMMIT="4cd030ad37bedff37345b37c1f1cd118530429ed"
+
+DESCRIPTION="Additional lexers for use in Pygments"
+HOMEPAGE="https://github.com/facelessuser/pymdown-lexers"
+SRC_URI="https://github.com/facelessuser/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~riscv x86"
+
+RDEPEND="
+ >=dev-python/pygments-2.0.1[${PYTHON_USEDEP}]
+"