summaryrefslogtreecommitdiff
path: root/dev-python/pymad
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-12-15 18:09:03 +0000
commit7bc9c63c9da678a7e6fceb095d56c634afd22c56 (patch)
tree4a67d50a439e9af63947e5f8b6ba3719af98b6c9 /dev-python/pymad
parentb284a3168fa91a038925d2ecf5e4791011ea5e7d (diff)
gentoo resync : 15.12.2019
Diffstat (limited to 'dev-python/pymad')
-rw-r--r--dev-python/pymad/Manifest6
-rw-r--r--dev-python/pymad/metadata.xml3
-rw-r--r--dev-python/pymad/pymad-0.10.ebuild22
-rw-r--r--dev-python/pymad/pymad-0.6-r1.ebuild26
4 files changed, 28 insertions, 29 deletions
diff --git a/dev-python/pymad/Manifest b/dev-python/pymad/Manifest
index 356c77be112d..7eb9375dfbbb 100644
--- a/dev-python/pymad/Manifest
+++ b/dev-python/pymad/Manifest
@@ -1,3 +1,3 @@
-DIST pymad-0.6.tar.gz 22099 BLAKE2B d0d63114bc24fd94b0f4b1e0d58324cc625772035315cbb6f62bf496c8090db446966a689de08c079f9389295e8efedd885cba5c989d86c31e3291838eb75103 SHA512 1493925cf0fca3ede8314071795736354e2f036f41a9e72cfcf77f960c84bba8e76b43ce7c389c15dc9f2f619ce77b0afae1b78558b1617240bdde3012ad753c
-EBUILD pymad-0.6-r1.ebuild 592 BLAKE2B 0f8960fd69e0284cec5b6872944b54724ce1a84ed734edfcc25d5197a1e85e2f64ac9ab5152f435ae6044513c53ebede80122903883aeef6cc5772ad080d3b0b SHA512 116a0620e3b014b0e7128fa4ccbe55803ba97eb319d123f5f1b5e6e5308f8ef7ba2f961d6ff2adf213381a64d0c89f714b37edea0058a2bf591b32a54ce90bba
-MISC metadata.xml 236 BLAKE2B 167eb58da19caba0e03167e2f209e118ce8a468851bca2790a0353112848fffcd72522497e5f951bf5c6eafa9691fa2a1ad980843cb4170a8194f3b8178ebe16 SHA512 0f2c2a0401b53543eac90eafdd4d11c5913be07f47b968e2892ca92c265adbd9564f02a491ff2607d7031194ba3e50c7720851537341b1541120821c487147a3
+DIST pymad-0.10.tar.gz 26815 BLAKE2B df694f1fcc7b2c6d0d0aa064b60d061ade2240085867b6a12b3ed63a93cbcac20ac40b3929fbf5b8d9c7b6dbc52883130d02b309ce7690addda6c78813ca2847 SHA512 68a7c93031d174ab50dfa406eec4166be2158d39c4231baee18b7d9c879692376cbf491bcd3e5747e65c496b07a40d1597532551aedcdf05d0fa46f6e185a3d8
+EBUILD pymad-0.10.ebuild 528 BLAKE2B 0d6d0c6aadaaa8408e18db0b943c26d51c133ad02021b0e02c5555bd6c7a7a0bfb1139b518a81a27c71116e7d465b9bbb65605f82d6153daa194a1e66e8f614e SHA512 113592a1350b2c6058cff2386cd4aff2e12596863f33d8acfb77efa94d280e0a2c47e13c809f496fb800a283476bb872a2a290d33dfc0f5693301fb9fc1dcc29
+MISC metadata.xml 310 BLAKE2B ebccbb3d64c5b67a00075bef2ee0bf4d4be2b15c2f661516274ebe5972f0db25667945f0f2917380be74df6e50f6d09d2625f94050f4bd2c10d2df819dd711b8 SHA512 5b6c98faed99761df114172e90e2a338530e9dd9c06c447cc661cbf63c2361364ab3f9fb34790a09122d6e570e51981e7c4d2091539ad9efacff8e39e5951123
diff --git a/dev-python/pymad/metadata.xml b/dev-python/pymad/metadata.xml
index 9e5274c5b4ae..e24cb2a46b11 100644
--- a/dev-python/pymad/metadata.xml
+++ b/dev-python/pymad/metadata.xml
@@ -5,4 +5,7 @@
<email>python@gentoo.org</email>
<name>Python</name>
</maintainer>
+<upstream>
+ <remote-id type="github">jaqx0r/pymad</remote-id>
+</upstream>
</pkgmetadata>
diff --git a/dev-python/pymad/pymad-0.10.ebuild b/dev-python/pymad/pymad-0.10.ebuild
new file mode 100644
index 000000000000..f05e37f069e7
--- /dev/null
+++ b/dev-python/pymad/pymad-0.10.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{5,6,7} )
+DISTUTILS_USE_SETUPTOOLS=no
+
+inherit distutils-r1
+
+DESCRIPTION="Python wrapper for libmad MP3 decoding in python"
+HOMEPAGE="https://github.com/jaqx0r/pymad"
+SRC_URI="https://github.com/jaqx0r/${PN}/archive/version/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+DEPEND="media-libs/libmad"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${PN}-version-${PV}"
diff --git a/dev-python/pymad/pymad-0.6-r1.ebuild b/dev-python/pymad/pymad-0.6-r1.ebuild
deleted file mode 100644
index 3fc1e7624ba2..000000000000
--- a/dev-python/pymad/pymad-0.6-r1.ebuild
+++ /dev/null
@@ -1,26 +0,0 @@
-# Copyright 1999-2016 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python2_7 )
-
-inherit distutils-r1
-
-DESCRIPTION="Python wrapper for libmad MP3 decoding in python"
-HOMEPAGE="http://www.spacepants.org/src/pymad/"
-SRC_URI="http://www.spacepants.org/src/pymad/download/${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="amd64 ppc x86"
-IUSE=""
-
-DEPEND="media-libs/libmad"
-RDEPEND="${DEPEND}"
-
-python_configure_all() {
- set -- "${PYTHON}" config_unix.py --prefix "${EPREFIX}/usr"
- echo "${@}"
- "${@}" || die "Configuration failed"
-}