summaryrefslogtreecommitdiff
path: root/dev-python/pymacaroons
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-30 03:02:28 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-10-30 03:02:28 +0000
commitb77e1a6cc7c668e135d139c5ec5ad0ae1c11b857 (patch)
tree41574d961a9788fa95e2a789a408e1c6fc151bd9 /dev-python/pymacaroons
parent009897642a869d630779716efc51af1554f72867 (diff)
gentoo auto-resync : 30:10:2022 - 03:02:28
Diffstat (limited to 'dev-python/pymacaroons')
-rw-r--r--dev-python/pymacaroons/Manifest2
-rw-r--r--dev-python/pymacaroons/pymacaroons-0.13.0-r1.ebuild49
2 files changed, 51 insertions, 0 deletions
diff --git a/dev-python/pymacaroons/Manifest b/dev-python/pymacaroons/Manifest
index abcce53e8176..2fd0b910ed05 100644
--- a/dev-python/pymacaroons/Manifest
+++ b/dev-python/pymacaroons/Manifest
@@ -1,3 +1,5 @@
+DIST pymacaroons-0.13.0-nose-to-pytest.patch 18750 BLAKE2B 36e884b77fa5d540f5c849a6dead98ad30a41b04a512d85843ffc7f18f85660a0520e6b17dd55f48c0ac1c0f98f86c0ea9751942a0592d2e64698aa9d9a65131 SHA512 36a582ad8395eb114a164d027b0d73cb6dfc10230538c0f7c3beb9b9afca26cd9a4964cd3f12cb144fd7e63acc0f7ce19760a9ad75be1f5a9a37ccc350462056
DIST pymacaroons-0.13.0.gh.tar.gz 25607 BLAKE2B ff21e88842c54f7ce84e8b3ad59d42ee43f2bb2073ebbb7f47dee123086c1466024420246a4da2eae462bc36e44a3621b75144846e090073c5063b0af24f1ad1 SHA512 60da7e03d68083f8effdc06b338dd04dbd6a39ff137373721af09f1282fb035f969459d2ef80f4d728dcf95f6244b7b2de443e48658e0551462ab46daf3884a2
+EBUILD pymacaroons-0.13.0-r1.ebuild 1115 BLAKE2B 0207c547ce90239450f15807e32c736a1bb31607a00948865db40b2b238ca13b24b1223aaeab226a030a144ccc565fd77fb62e5286f0df58012e139cf7ffb60c SHA512 f4a16418bad30a79ac296601930482fe81b670ef61afde7cf30475fe6971a561ad44d70e0f06178886461c80b311c31881b530d936c798d797980080b93552e6
EBUILD pymacaroons-0.13.0.ebuild 973 BLAKE2B 70cd270930b0d90fa0143d2505885a3142c216926c9b45ba77b3c9d6dff77414dc9dbf5ffdfe80db7dbcbfbe4bc1a7a0a6757cbadbd388ca89c5f5a69e4408df SHA512 30cf4ea2d9bed794fdb80b8a0a08214dd29c9419d16d9f54a5e94b20520869d0745ee453c31ed5159e32e31bcf5130c944c6a7adefc9a499ab79608b5e1ee9f5
MISC metadata.xml 549 BLAKE2B 145859908f287edddf1a18d8fad75d8dab11bdaf4746e822d47986a870530ac94b6e8e4dc6962b52cc78e38ac55be9c5f37fc1f464b2dded3067b1124192fb90 SHA512 15b654a0c31ebdd610b7473cb0057fa9e2e779fc0d4cab1e725e08a6c3a1e5e802de2313bd7d8174ac39e880d92edcb0d4198760dbd9b806c623c5b844cde91c
diff --git a/dev-python/pymacaroons/pymacaroons-0.13.0-r1.ebuild b/dev-python/pymacaroons/pymacaroons-0.13.0-r1.ebuild
new file mode 100644
index 000000000000..b0bc4372dffe
--- /dev/null
+++ b/dev-python/pymacaroons/pymacaroons-0.13.0-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python implementation of Macaroons"
+HOMEPAGE="
+ https://github.com/ecordell/pymacaroons
+ https://pypi.org/project/pymacaroons/
+"
+SRC_URI="
+ https://github.com/ecordell/pymacaroons/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ https://github.com/arkamar/pymacaroons/commit/backport-upstream-pr59.patch
+ -> ${P}-nose-to-pytest.patch
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64"
+
+RDEPEND="
+ dev-python/pynacl[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ # The patch is backported from upstream PR #59 to v0.13.0 and stored in my
+ # fork, see SRC_URI.
+ "${DISTDIR}/${P}-nose-to-pytest.patch"
+)
+
+EPYTEST_IGNORE=(
+ # The package also contains property_tests, however, they are incompatible
+ # with dev-python/hypothesis in gentoo. The package requires too old version.
+ tests/property_tests
+)
+
+distutils_enable_tests pytest