summaryrefslogtreecommitdiff
path: root/dev-python/pymacaroons/pymacaroons-0.13.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-15 07:41:50 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-15 07:41:50 +0100
commitb3f2504c1d05b5999b74b2135860fc721e3adf68 (patch)
treee11656067365c7d474553833d6202ed04d3324a5 /dev-python/pymacaroons/pymacaroons-0.13.0.ebuild
parente0fdb8199de0e7a9b7c72d7f38d2e3ddaecdacd0 (diff)
gentoo auto-resync : 15:07:2022 - 07:41:50
Diffstat (limited to 'dev-python/pymacaroons/pymacaroons-0.13.0.ebuild')
-rw-r--r--dev-python/pymacaroons/pymacaroons-0.13.0.ebuild16
1 files changed, 13 insertions, 3 deletions
diff --git a/dev-python/pymacaroons/pymacaroons-0.13.0.ebuild b/dev-python/pymacaroons/pymacaroons-0.13.0.ebuild
index 24e60796d20c..fc5b6826c9b4 100644
--- a/dev-python/pymacaroons/pymacaroons-0.13.0.ebuild
+++ b/dev-python/pymacaroons/pymacaroons-0.13.0.ebuild
@@ -18,12 +18,22 @@ SRC_URI="https://github.com/ecordell/pymacaroons/archive/v${PV}.tar.gz -> ${P}.g
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64"
+IUSE="test"
-# tests are incompatible with dev-python/hypothesis::gentoo. This package needs
-# <2.0.0, because needed hypothesis.specifiers module was removed in 2.0.0.
-RESTRICT="test"
+RESTRICT="!test? ( test )"
RDEPEND="
dev-python/pynacl[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]
"
+BDEPEND="test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ # The package also contains property_tests, however, they are incompatible
+ # with dev-python/hypothesis in gentoo. The package requires too old version.
+ "${EPYTHON}" -m nose -v tests/functional_tests || die "Tests failed with ${EPYTHON}"
+}