summaryrefslogtreecommitdiff
path: root/dev-python/pymacaroons/pymacaroons-0.13.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
commit2719f73b6813d11d13a9650cdd2ab8ec6e69385d (patch)
tree8c816148bcbd22757d892089c989ae614eae4f5a /dev-python/pymacaroons/pymacaroons-0.13.0.ebuild
parent0f558761aa2dee1017b4751e4017205e015a9560 (diff)
gentoo resync : 09.07.2022
Diffstat (limited to 'dev-python/pymacaroons/pymacaroons-0.13.0.ebuild')
-rw-r--r--dev-python/pymacaroons/pymacaroons-0.13.0.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/pymacaroons/pymacaroons-0.13.0.ebuild b/dev-python/pymacaroons/pymacaroons-0.13.0.ebuild
new file mode 100644
index 000000000000..24e60796d20c
--- /dev/null
+++ b/dev-python/pymacaroons/pymacaroons-0.13.0.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="PyMacaroons is a Python implementation of Macaroons."
+HOMEPAGE="
+ https://github.com/ecordell/pymacaroons
+ https://pypi.org/project/pymacaroons/
+"
+SRC_URI="https://github.com/ecordell/pymacaroons/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# tests are incompatible with dev-python/hypothesis::gentoo. This package needs
+# <2.0.0, because needed hypothesis.specifiers module was removed in 2.0.0.
+RESTRICT="test"
+
+RDEPEND="
+ dev-python/pynacl[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"