summaryrefslogtreecommitdiff
path: root/dev-python/pymacaroons/pymacaroons-0.13.0-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-30 03:02:28 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-10-30 03:02:28 +0000
commitb77e1a6cc7c668e135d139c5ec5ad0ae1c11b857 (patch)
tree41574d961a9788fa95e2a789a408e1c6fc151bd9 /dev-python/pymacaroons/pymacaroons-0.13.0-r1.ebuild
parent009897642a869d630779716efc51af1554f72867 (diff)
gentoo auto-resync : 30:10:2022 - 03:02:28
Diffstat (limited to 'dev-python/pymacaroons/pymacaroons-0.13.0-r1.ebuild')
-rw-r--r--dev-python/pymacaroons/pymacaroons-0.13.0-r1.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/pymacaroons/pymacaroons-0.13.0-r1.ebuild b/dev-python/pymacaroons/pymacaroons-0.13.0-r1.ebuild
new file mode 100644
index 000000000000..b0bc4372dffe
--- /dev/null
+++ b/dev-python/pymacaroons/pymacaroons-0.13.0-r1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A Python implementation of Macaroons"
+HOMEPAGE="
+ https://github.com/ecordell/pymacaroons
+ https://pypi.org/project/pymacaroons/
+"
+SRC_URI="
+ https://github.com/ecordell/pymacaroons/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+ https://github.com/arkamar/pymacaroons/commit/backport-upstream-pr59.patch
+ -> ${P}-nose-to-pytest.patch
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64"
+
+RDEPEND="
+ dev-python/pynacl[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/mock[${PYTHON_USEDEP}]
+ )
+"
+
+PATCHES=(
+ # The patch is backported from upstream PR #59 to v0.13.0 and stored in my
+ # fork, see SRC_URI.
+ "${DISTDIR}/${P}-nose-to-pytest.patch"
+)
+
+EPYTEST_IGNORE=(
+ # The package also contains property_tests, however, they are incompatible
+ # with dev-python/hypothesis in gentoo. The package requires too old version.
+ tests/property_tests
+)
+
+distutils_enable_tests pytest