summaryrefslogtreecommitdiff
path: root/dev-python/pylzma
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/pylzma
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pylzma')
-rw-r--r--dev-python/pylzma/Manifest3
-rw-r--r--dev-python/pylzma/metadata.xml11
-rw-r--r--dev-python/pylzma/pylzma-0.4.9.ebuild31
3 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/pylzma/Manifest b/dev-python/pylzma/Manifest
new file mode 100644
index 000000000000..ba9323aab47a
--- /dev/null
+++ b/dev-python/pylzma/Manifest
@@ -0,0 +1,3 @@
+DIST pylzma-0.4.9.gh.tar.gz 4083321 BLAKE2B de9ec578665b05b9d13370293f1e119d9bdfd4ba63b3c9d5168b794f82cee5a1cce6dbe45d5bc92d6714c0b56759dab9e578c63b6821754bd01b2aa66c34895b SHA512 d2316fcab50e4571a590985db8f132488cc4e12a45ecbcd5d21c356c4867bad671eed2e4ffda64735eb5b7e34f173a77fad65ebac9915a43cc9a17cbcf1ac62e
+EBUILD pylzma-0.4.9.ebuild 821 BLAKE2B a257a717c918b91fdcbd050c470314193fc850c5a19827f045fd17de934c1480ffca8a63bc9f5a598a77c344209297d7589218be9c61ca76924eee5218ff246c SHA512 2ca5b7b9e09d9c4a60fcc5a4f36652dced81d177c261e29d7862c1223a042a9c049a49f3c336f17b436363e89e7620e2ec48505bdc0434528c8c847165902b37
+MISC metadata.xml 309 BLAKE2B 7cc33bb32635e06c0b8aa5668260dbc03eb1fca3beb9eca60a10c08a28ccc9df2bf9a7b0009746b5bf5cabda9c0a5ae8b0b005d1e45770ac7d8202d41f0beab2 SHA512 2511d647822514d4571c14fd77677fcf275300b12c748645696218608cb0baea9603c1de13599f1ec839783fbe1a99447a0b9c5cfb6be3ed1b354420815daaca
diff --git a/dev-python/pylzma/metadata.xml b/dev-python/pylzma/metadata.xml
new file mode 100644
index 000000000000..6171c645d955
--- /dev/null
+++ b/dev-python/pylzma/metadata.xml
@@ -0,0 +1,11 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>python@gentoo.org</email>
+ <name>Python</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">pylzma</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pylzma/pylzma-0.4.9.ebuild b/dev-python/pylzma/pylzma-0.4.9.ebuild
new file mode 100644
index 000000000000..92ad185327ee
--- /dev/null
+++ b/dev-python/pylzma/pylzma-0.4.9.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=(python2_7)
+inherit distutils-r1
+
+DESCRIPTION="Python bindings for the LZMA compression library"
+HOMEPAGE="https://www.joachim-bauch.de/projects/pylzma/
+ https://pypi.org/project/pylzma/"
+# pypi tarball does not include test data
+SRC_URI="https://github.com/fancycode/pylzma/archive/v${PV}.tar.gz -> ${P}.gh.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE=""
+
+RDEPEND=""
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
+
+DOCS=(doc/USAGE.md README.md)
+
+python_compile() {
+ python_is_python3 || local -x CFLAGS="${CFLAGS} -fno-strict-aliasing"
+ distutils-r1_python_compile
+}
+
+python_test() {
+ "${PYTHON}" -m unittest discover -v || die "Tests fail with ${EPYTHON}"
+}