summaryrefslogtreecommitdiff
path: root/dev-python/pylibmc
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-06-21 17:50:24 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-06-21 17:50:24 +0100
commitfeb0daf81d888e9160f9f94502de09b66f2a63fd (patch)
treeb6e5c40ce2abef3da27ed50a023153f475e0ddef /dev-python/pylibmc
parent9452a6e87b6c2c70513bc47a2470bf9f1168920e (diff)
gentoo resync : 21.06.2020
Diffstat (limited to 'dev-python/pylibmc')
-rw-r--r--dev-python/pylibmc/Manifest2
-rw-r--r--dev-python/pylibmc/pylibmc-1.6.1-r1.ebuild52
2 files changed, 23 insertions, 31 deletions
diff --git a/dev-python/pylibmc/Manifest b/dev-python/pylibmc/Manifest
index 876363f8b7f4..cc28b26026e4 100644
--- a/dev-python/pylibmc/Manifest
+++ b/dev-python/pylibmc/Manifest
@@ -1,4 +1,4 @@
AUX pylibmc-1.6.1-fix-test-failures-r1.patch 516 BLAKE2B b471ca80b11beff5ac0119f5eafaf437a74022c977a884b8bdf4ef2afdb3d535ad6602db9b1206fb6649bf57ffe5bbd17509d3dda3b6604fcfa428b592dbeae3 SHA512 802337b66cbd188cc81208420448da24cecde3c01d435d6814437f0ee31850b6ef8a53f61647740da340a69971e5fe570cc2a8c1b31226e425ce7ff88bca101c
DIST pylibmc-1.6.1.tar.gz 72061 BLAKE2B ebaa6f9dfc341d862a8b46bbbf0db1420ff400cb40390f7bee6bf198ff941ad7967b578040ffe1209721ea84a163a39649108a2a23f3dadc2d579db740b2ccf3 SHA512 a3874435389486b29bab5f1d29e5c179d67655d90995bb27fcb7cd46ce7eb3b60117b94f901602f8a65dc0e587d5f8edfcf15e259effd439411adb58ddb7065e
-EBUILD pylibmc-1.6.1-r1.ebuild 2005 BLAKE2B 14a0e3a2fc9697d5d7d380dcc11a47afdc726047c3cbaae42eaa61896d0af8ea76d152102d2a08bca411642b103572c24e01befaff499d506a4f73ac8a9d7852 SHA512 a6f1c461625d617551140f03ae51c4597ef24d9f904365822d334f0e5ea6273fe94e763a94415d218234cdbadbfc20ae1b2539c8bbc70b5050a4ba4eb577f16a
+EBUILD pylibmc-1.6.1-r1.ebuild 1533 BLAKE2B 4e6154fe0dae4b8f18780176f623cc19c3911071070ef45681bd953f1449514676bfa4b97be48baf203bb630e1756e5276cac2186c9f07c7e751f82bc5eb29c8 SHA512 4892d7c6b72d2e5fac2584ca7e4c7e8d82a6446fac26bc7d807ee635ff760eaf63a165b8ce465af29cf4d8bf7b63b88c942b6d7b287deb255d63f79bda38b5b2
MISC metadata.xml 366 BLAKE2B 5dcc369c40a052fcc6ff72c6f8fc46ffc8334c1a91e3f2e8ba8f9bf0bea7414d91833e5627f3d53b10e9d3d9f230b0af333929820a616433ff9d439cae888d2d SHA512 974f19bd4dd8043c07fa0001072e25b553aa82f4b9e9c00e579cb88e8819a4411a04b2e59cace18e0a8e2ce7395057e520b0bc78435865c4536b3de2e402265d
diff --git a/dev-python/pylibmc/pylibmc-1.6.1-r1.ebuild b/dev-python/pylibmc/pylibmc-1.6.1-r1.ebuild
index 42727e34ff9c..c07978f38906 100644
--- a/dev-python/pylibmc/pylibmc-1.6.1-r1.ebuild
+++ b/dev-python/pylibmc/pylibmc-1.6.1-r1.ebuild
@@ -2,12 +2,17 @@
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-PYTHON_COMPAT=( python3_{6,7,8} )
+
+DISTUTILS_USE_SETUPTOOLS=no
+PYTHON_COMPAT=( python3_{6..9} )
inherit distutils-r1
DESCRIPTION="Libmemcached wrapper written as a Python extension"
-HOMEPAGE="http://sendapatch.se/projects/pylibmc/ https://pypi.org/project/pylibmc/"
+HOMEPAGE="
+ https://sendapatch.se/projects/pylibmc/
+ https://pypi.org/project/pylibmc/
+ https://github.com/lericson/pylibmc/"
# One image is missing from the doc at PyPI
# https://github.com/lericson/pylibmc/pull/221
SRC_URI="https://github.com/lericson/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
@@ -15,35 +20,24 @@ SRC_URI="https://github.com/lericson/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 x86"
-IUSE="doc test"
-
-# implementations to use for building docs, separate from PYTHON_COMPAT since
-# dev-python/sphinx might not be available everywhere
-DOCS_PYTHON_COMPAT=( python{2_7,3_{6,7}} )
+IUSE="test"
+RESTRICT="!test? ( test )"
RDEPEND=">=dev-libs/libmemcached-0.32"
# Older sphinx versions fail to compile the doc
# https://github.com/sphinx-doc/sphinx/issues/3266
-BDEPEND="${RDEPEND}
- doc? ( $(python_gen_cond_dep '
- >=dev-python/sphinx-1.5.1-r1[${PYTHON_USEDEP}]' "${DOCS_PYTHON_COMPAT[@]}")
- )
+DEPEND="${RDEPEND}"
+BDEPEND="
test? (
net-misc/memcached
dev-python/nose[${PYTHON_USEDEP}]
)"
-RESTRICT="!test? ( test )"
-
-REQUIRED_USE="doc? ( || ( $(python_gen_useflags "${DOCS_PYTHON_COMPAT[@]}") ) )"
-
PATCHES=(
"${FILESDIR}/pylibmc-1.6.1-fix-test-failures-r1.patch"
)
-pkg_setup() {
- use doc && DISTUTILS_ALL_SUBPHASE_IMPLS=( "${DOCS_PYTHON_COMPAT[@]}" )
-}
+distutils_enable_sphinx docs
python_prepare_all() {
sed -e "/with-info=1/d" -i setup.cfg || die
@@ -51,22 +45,20 @@ python_prepare_all() {
# some amazon thing, expects to be in AWS
rm tests/test_autoconf.py || die
distutils-r1_python_prepare_all
+
+ # needed for docs
+ export PYLIBMC_DIR=.
}
-python_compile_all() {
- if use doc; then
- # This variable is added to sys.path
- # but it does not seem to be useful
- PYLIBMC_DIR="." emake -C docs
- HTML_DOCS=( docs/_build/html/. )
- fi
+src_test() {
+ local -x MEMCACHED_PORT=11219
+ memcached -d -p "${MEMCACHED_PORT}" -u nobody -l localhost \
+ -P "${T}/m.pid" || die
+ distutils-r1_src_test
+ kill "$(<"${T}/m.pid")" || die
}
python_test() {
distutils_install_for_testing
- memcached -d -p 11219 -u nobody -l localhost -P "${T}/m.pid" || die
- MEMCACHED_PORT=11219 nosetests -v
- local ret=${?}
- kill "$(<"${T}/m.pid")" || die
- [[ ${ret} == 0 ]] || die "Tests fail with ${EPYTHON}!"
+ nosetests -v || die "Tests failed with ${EPYTHON}"
}