summaryrefslogtreecommitdiff
path: root/dev-python/pylatex/pylatex-1.4.1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
commite68d405c5d712af4387159df07e226217bdda049 (patch)
tree009ab0f3d427f0813e62930d71802cb054c07e30 /dev-python/pylatex/pylatex-1.4.1.ebuild
parent401101f9c8077911929d3f2b60a37098460a5d89 (diff)
gentoo resync : 06.04.2022
Diffstat (limited to 'dev-python/pylatex/pylatex-1.4.1.ebuild')
-rw-r--r--dev-python/pylatex/pylatex-1.4.1.ebuild13
1 files changed, 10 insertions, 3 deletions
diff --git a/dev-python/pylatex/pylatex-1.4.1.ebuild b/dev-python/pylatex/pylatex-1.4.1.ebuild
index e22369be0021..bb22065092e9 100644
--- a/dev-python/pylatex/pylatex-1.4.1.ebuild
+++ b/dev-python/pylatex/pylatex-1.4.1.ebuild
@@ -1,12 +1,13 @@
-# Copyright 2020-2021 Gentoo Authors
+# Copyright 2020-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
MY_PN="PyLaTeX"
MY_P="${MY_PN}-${PV}"
-PYTHON_COMPAT=( python3_{7,8,9} )
+PYTHON_COMPAT=( python3_{7..10} )
+DISTUTILS_USE_PEP517=setuptools
inherit distutils-r1 optfeature
@@ -35,6 +36,12 @@ BDEPEND+="
dev-texlive/texlive-latexextra
)"
+python_prepare_all() {
+ sed -i -e 's:description-file:description_file:' setup.cfg || die # bug 798381
+
+ distutils-r1_python_prepare_all
+}
+
python_install_all() {
if use examples ; then
dodoc -r examples