summaryrefslogtreecommitdiff
path: root/dev-python/pylast/pylast-5.1.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-10-26 03:54:55 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-10-26 03:54:55 +0100
commit2ecd7994be1409f2a65bfca700904d2a78fd7bbe (patch)
tree0248ea4d4f411ea88c27470c15ebc725bb04baa1 /dev-python/pylast/pylast-5.1.0.ebuild
parentc22e93ab35a8cb604c41623a7b2cda059c462b70 (diff)
gentoo auto-resync : 26:10:2022 - 03:54:55
Diffstat (limited to 'dev-python/pylast/pylast-5.1.0.ebuild')
-rw-r--r--dev-python/pylast/pylast-5.1.0.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/pylast/pylast-5.1.0.ebuild b/dev-python/pylast/pylast-5.1.0.ebuild
new file mode 100644
index 000000000000..07ac0a967207
--- /dev/null
+++ b/dev-python/pylast/pylast-5.1.0.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=hatchling
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python interface to last.fm and other api-compatible websites"
+HOMEPAGE="
+ https://pypi.org/project/pylast/
+ https://github.com/pylast/pylast/
+"
+SRC_URI="
+ https://github.com/pylast/pylast/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+
+RDEPEND="
+ dev-python/httpx[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ dev-python/hatch-vcs[${PYTHON_USEDEP}]
+ test? (
+ dev-python/flaky[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}