summaryrefslogtreecommitdiff
path: root/dev-python/pylama/pylama-8.4.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-26 19:56:43 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-26 19:56:43 +0000
commit236302aac694377916670b7769f941e3f1dd0bbc (patch)
tree0a81f35a6120e176fc267d7ad981d4734d85c8ba /dev-python/pylama/pylama-8.4.1-r1.ebuild
parent7267fb40fb51ddbc9cc5c1c82b0a12807ef7b281 (diff)
gentoo auto-resync : 26:01:2023 - 19:56:42
Diffstat (limited to 'dev-python/pylama/pylama-8.4.1-r1.ebuild')
-rw-r--r--dev-python/pylama/pylama-8.4.1-r1.ebuild54
1 files changed, 54 insertions, 0 deletions
diff --git a/dev-python/pylama/pylama-8.4.1-r1.ebuild b/dev-python/pylama/pylama-8.4.1-r1.ebuild
new file mode 100644
index 000000000000..c1a76432c6e9
--- /dev/null
+++ b/dev-python/pylama/pylama-8.4.1-r1.ebuild
@@ -0,0 +1,54 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Code audit tool for python"
+HOMEPAGE="
+ https://github.com/klen/pylama/
+ https://pypi.org/project/pylama/
+"
+SRC_URI="
+ https://github.com/klen/pylama/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86"
+
+RDEPEND="
+ >=dev-python/mccabe-0.7.0[${PYTHON_USEDEP}]
+ >=dev-python/pycodestyle-2.9.1[${PYTHON_USEDEP}]
+ >=dev-python/pydocstyle-6.1.1[${PYTHON_USEDEP}]
+ >=dev-python/pyflakes-2.5.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/eradicate[${PYTHON_USEDEP}]
+ dev-python/mypy[${PYTHON_USEDEP}]
+ dev-python/pylint[${PYTHON_USEDEP}]
+ dev-python/radon[${PYTHON_USEDEP}]
+ dev-vcs/git
+ $(python_gen_cond_dep '
+ dev-python/tomli[${PYTHON_USEDEP}]
+ ' 3.{8..10})
+ )
+"
+
+distutils_enable_tests pytest
+
+PATCHES=(
+ "${FILESDIR}"/${P}-tomli.patch
+)
+
+EPYTEST_DESELECT=(
+ # not packaged
+ tests/test_linters.py::test_quotes
+ tests/test_linters.py::test_vulture
+)