summaryrefslogtreecommitdiff
path: root/dev-python/pylama/pylama-8.4.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-02 17:45:32 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-02 17:45:32 +0000
commit5939313f229e6fcf374fb7e9ee4f8675b05ab293 (patch)
tree0a8181cbc5d052ab4d26a8e1d2dc52f126063fc6 /dev-python/pylama/pylama-8.4.1-r1.ebuild
parent7e3d6dcede5749fe6a1adef4e673a9dde7703b7b (diff)
gentoo auto-resync : 02:02:2024 - 17:45:32
Diffstat (limited to 'dev-python/pylama/pylama-8.4.1-r1.ebuild')
-rw-r--r--dev-python/pylama/pylama-8.4.1-r1.ebuild55
1 files changed, 0 insertions, 55 deletions
diff --git a/dev-python/pylama/pylama-8.4.1-r1.ebuild b/dev-python/pylama/pylama-8.4.1-r1.ebuild
deleted file mode 100644
index 30c5ca59c22f..000000000000
--- a/dev-python/pylama/pylama-8.4.1-r1.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2023 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=8
-
-DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{9..11} )
-
-inherit distutils-r1
-
-DESCRIPTION="Code audit tool for python"
-HOMEPAGE="
- https://github.com/klen/pylama/
- https://pypi.org/project/pylama/
-"
-SRC_URI="
- https://github.com/klen/pylama/archive/${PV}.tar.gz
- -> ${P}.gh.tar.gz
-"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~mips ppc ppc64 ~riscv ~s390 sparc x86"
-
-RDEPEND="
- >=dev-python/mccabe-0.7.0[${PYTHON_USEDEP}]
- >=dev-python/pycodestyle-2.9.1[${PYTHON_USEDEP}]
- >=dev-python/pydocstyle-6.1.1[${PYTHON_USEDEP}]
- >=dev-python/pyflakes-2.5.0[${PYTHON_USEDEP}]
-"
-BDEPEND="
- test? (
- dev-python/eradicate[${PYTHON_USEDEP}]
- dev-python/mypy[${PYTHON_USEDEP}]
- dev-python/pylint[${PYTHON_USEDEP}]
- dev-python/radon[${PYTHON_USEDEP}]
- dev-vcs/git
- $(python_gen_cond_dep '
- dev-python/tomli[${PYTHON_USEDEP}]
- ' 3.{8..10})
- )
-"
-
-distutils_enable_tests pytest
-
-PATCHES=(
- "${FILESDIR}"/${P}-tomli.patch
- "${FILESDIR}"/${P}-dummy-elif.patch
-)
-
-EPYTEST_DESELECT=(
- # not packaged
- tests/test_linters.py::test_quotes
- tests/test_linters.py::test_vulture
-)