summaryrefslogtreecommitdiff
path: root/dev-python/pyjwt/pyjwt-1.7.1-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-06-29 12:04:12 +0100
commit0f558761aa2dee1017b4751e4017205e015a9560 (patch)
tree037df795519468a25d9362b4e95cdaeb84eb1cf9 /dev-python/pyjwt/pyjwt-1.7.1-r1.ebuild
parent752d6256e5204b958b0ef7905675a940b5e9172f (diff)
gentoo resync : 29.12.2022
Diffstat (limited to 'dev-python/pyjwt/pyjwt-1.7.1-r1.ebuild')
-rw-r--r--dev-python/pyjwt/pyjwt-1.7.1-r1.ebuild55
1 files changed, 0 insertions, 55 deletions
diff --git a/dev-python/pyjwt/pyjwt-1.7.1-r1.ebuild b/dev-python/pyjwt/pyjwt-1.7.1-r1.ebuild
deleted file mode 100644
index 1849483dffc3..000000000000
--- a/dev-python/pyjwt/pyjwt-1.7.1-r1.ebuild
+++ /dev/null
@@ -1,55 +0,0 @@
-# Copyright 1999-2021 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-DISTUTILS_USE_SETUPTOOLS=rdepend
-PYTHON_COMPAT=( python3_{7..9} pypy3 )
-
-inherit distutils-r1 optfeature
-
-MY_PN="PyJWT"
-DESCRIPTION="JSON Web Token implementation in Python"
-HOMEPAGE="https://github.com/progrium/pyjwt https://pypi.org/project/PyJWT/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
-S="${WORKDIR}"/${MY_PN}-${PV}
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 ~arm arm64 ppc ~ppc64 sparc x86 ~amd64-linux ~x86-linux"
-
-RDEPEND=""
-DEPEND="
- test? (
- >=dev-python/cryptography-1.4.0[${PYTHON_USEDEP}]
- )"
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- find . -name '__pycache__' -prune -exec rm -rf {} + || die
- find . -name '*.pyc' -delete || die
-
- # enables coverage, we don't need that
- rm setup.cfg || die
- # kill tests using pycrypto that break with pycryptodome
- sed -i -e '/has_pycrypto/s:True:False:' \
- tests/contrib/test_algorithms.py || die
-
- local PATCHES=(
- "${FILESDIR}"/pyjwt-1.7.1-ecdsa-fix.patch
- )
-
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- pytest -vv || die "Tests fail with ${EPYTHON}"
-}
-
-pkg_postinst() {
- optfeature "cryptography" dev-python/cryptography
- optfeature "flake8" dev-python/flake8{,-import-order}
-
- ewarn "flake8 feature requires 'pep8-naming' which is not packaged yet"
-}