summaryrefslogtreecommitdiff
path: root/dev-python/pyjsparser/pyjsparser-2.7.1_p20190421-r2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-16 05:56:39 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-16 05:56:39 +0000
commit433cb2e828d414c74b16d429f40d25e179b0a70f (patch)
treeaf337fbb3c6591c911ea3b25ff43883e9144b506 /dev-python/pyjsparser/pyjsparser-2.7.1_p20190421-r2.ebuild
parent038c98389fa5a5efb22cffaa35ecdddfc9a38036 (diff)
gentoo auto-resync : 16:01:2023 - 05:56:39
Diffstat (limited to 'dev-python/pyjsparser/pyjsparser-2.7.1_p20190421-r2.ebuild')
-rw-r--r--dev-python/pyjsparser/pyjsparser-2.7.1_p20190421-r2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/pyjsparser/pyjsparser-2.7.1_p20190421-r2.ebuild b/dev-python/pyjsparser/pyjsparser-2.7.1_p20190421-r2.ebuild
new file mode 100644
index 000000000000..47b017d915d6
--- /dev/null
+++ b/dev-python/pyjsparser/pyjsparser-2.7.1_p20190421-r2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+H=5465d037b30e334cb0997f2315ec1e451b8ad4c1
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="Fast javascript parser based on esprima.js"
+HOMEPAGE="https://github.com/PiotrDabkowski/pyjsparser/
+ https://pypi.org/project/pyjsparser/"
+SRC_URI="https://github.com/PiotrDabkowski/${PN}/archive/${H}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}"/${PN}-${H}
+
+RESTRICT="!test? ( test )"
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 ~arm arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc x86"
+IUSE="test"
+
+BDEPEND="
+ test? (
+ dev-python/js2py[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ "${EPYTHON}" ./test_runner.py || die "tests failed with ${EPYTHON}"
+}