summaryrefslogtreecommitdiff
path: root/dev-python/pyinotify
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-15 19:43:32 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-15 19:43:32 +0100
commitfa1962ff69701bd9c0f15fb225cdbfb487125e0e (patch)
tree85b35bd5a3c73ea562768237a25da176adef5744 /dev-python/pyinotify
parentbd8ca999980e9c0c9ae40a11789c858bb58769e3 (diff)
gentoo auto-resync : 15:07:2022 - 19:43:32
Diffstat (limited to 'dev-python/pyinotify')
-rw-r--r--dev-python/pyinotify/Manifest3
-rw-r--r--dev-python/pyinotify/metadata.xml1
-rw-r--r--dev-python/pyinotify/pyinotify-0.9.6-r1.ebuild30
3 files changed, 33 insertions, 1 deletions
diff --git a/dev-python/pyinotify/Manifest b/dev-python/pyinotify/Manifest
index 3d284e5a95de..ebecb5477699 100644
--- a/dev-python/pyinotify/Manifest
+++ b/dev-python/pyinotify/Manifest
@@ -1,3 +1,4 @@
DIST pyinotify-0.9.6.tar.gz 60998 BLAKE2B 7fb55cfe5b2c02682b5842d95859a58f218ab591a4eee689b707e804c6fe8cde4cc1fb3dfbf54a044ff743deefa0ee5551bc6e27ca4dda1c608218a6c24597b2 SHA512 b52de43293b06b32236e90b7c33fac061f3095cd7d4aecec89a099d56020db1a85440ab9dcc8b521238c001fc49a1f37d1b16d621bc1acab4d7273aebcaadbc5
+EBUILD pyinotify-0.9.6-r1.ebuild 775 BLAKE2B 67f4b767545ca6992a20d501f66ffb87abb9bcb355b8306e9c885a30b7a3a16c061dfb42f94f154ef5024579c248fe1ff8e2b0fee24a4923278b2901b47af740 SHA512 4ca4e6660c86c1bbad842a4687fea777df448f052a89e990cda58558aa6302c6dc207c0e716f9714194895f8e7f124f46a304d756e78b06d8a4354bcf7a9e710
EBUILD pyinotify-0.9.6.ebuild 735 BLAKE2B ce89673e9867029b172ebd469b8908103a05eadf2772347075eb7f919a45f9fd74a7e87e92a06fe667a6faf010600516658915d377a20945984fe517a4b0eb56 SHA512 556b10149750474008f6389d68f4a1e2e982755719e0643a591605490c83aae8b24f707d1f0f930ca1bf1ab1301712782afac90b1b3af61df9f61e868c708cb0
-MISC metadata.xml 368 BLAKE2B 23d0244f92325d3db643e934c0daf89e543ba07df7477c2ff871ab2d1ee027950979b8fba7e13bd4be3bf2cacf512e9a382c4d18d17e53c38dc2a0c74fe5e49d SHA512 44e1afb1c3889273ed10d4401dfc3cd5fd858f3e09ecf6611e39a418ea290c69290da967139c6ca4e299e8e64f8e066555ecbe28a30e213c00951b94e2cb3921
+MISC metadata.xml 392 BLAKE2B 2a93eeba71631eaa13849f4a378cd7e8ddaba38e1e22c8b7baea9e8c81f0e922cde667a9088590b88b0c374f9aad8251bf8f8f2076c3bf4611c1927e941d6987 SHA512 0efd77ede60fbd00ed4b452455fe7bef88e53ddecb5eef808474251f0cd87c8c87749a6f260f76c5dadb2e4d913109602707857a403925b6b20e26f56dfdc9b3
diff --git a/dev-python/pyinotify/metadata.xml b/dev-python/pyinotify/metadata.xml
index 5925bf091b0b..18d7804baccb 100644
--- a/dev-python/pyinotify/metadata.xml
+++ b/dev-python/pyinotify/metadata.xml
@@ -5,6 +5,7 @@
<email>python@gentoo.org</email>
<name>Python</name>
</maintainer>
+ <stabilize-allarches/>
<upstream>
<remote-id type="pypi">pyinotify</remote-id>
<remote-id type="github">seb-m/pyinotify</remote-id>
diff --git a/dev-python/pyinotify/pyinotify-0.9.6-r1.ebuild b/dev-python/pyinotify/pyinotify-0.9.6-r1.ebuild
new file mode 100644
index 000000000000..79b5872dce8c
--- /dev/null
+++ b/dev-python/pyinotify/pyinotify-0.9.6-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
+PYTHON_REQ_USE="threads(+)"
+
+inherit distutils-r1
+
+DESCRIPTION="Python module used for monitoring filesystems events"
+HOMEPAGE="
+ https://pypi.org/project/pyinotify/
+ https://github.com/seb-m/pyinotify/"
+SRC_URI="https://seb.dbzteam.org/pub/pyinotify/releases/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux"
+IUSE="examples"
+
+python_install_all() {
+ if use examples; then
+ dodoc -r python3/examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+
+ distutils-r1_python_install_all
+}