summaryrefslogtreecommitdiff
path: root/dev-python/pyilmbase
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-05-18 00:10:51 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-05-18 00:10:51 +0100
commiteccb70a7f91b2d22582587f26d1a28bb31408b45 (patch)
tree3223e1fd54201bcf4ebecac6fbe87361cbe643e2 /dev-python/pyilmbase
parenta2810985afabcc31d3eace5e61d8ea25b852ba17 (diff)
gentoo resync : 18.05.2019
Diffstat (limited to 'dev-python/pyilmbase')
-rw-r--r--dev-python/pyilmbase/Manifest2
-rw-r--r--dev-python/pyilmbase/pyilmbase-2.3.0.ebuild11
2 files changed, 10 insertions, 3 deletions
diff --git a/dev-python/pyilmbase/Manifest b/dev-python/pyilmbase/Manifest
index 1cce9abcd36c..62062fc856bf 100644
--- a/dev-python/pyilmbase/Manifest
+++ b/dev-python/pyilmbase/Manifest
@@ -4,5 +4,5 @@ AUX pyilmbase-2.3.0-link-pyimath.patch 454 BLAKE2B 5e2bc6d09bb7012f8d0087aa0d76b
DIST pyilmbase-2.2.0.tar.gz 469927 BLAKE2B 74a806f30bf8881a4c58135110c3e805b9748074eab08e9afa17735630ee7de16ffe6a797ced926bb93d122eafdeb04c5e6e80ddba1a90bc551cb87ddeb30671 SHA512 111deb65a73b4d0454454d4fb64d09165fb25aad2e5714e35510c2b7ef301dc8765041de3188c2f89c9bd2770494a55a24372953fcda8dcedb23c401137e4344
DIST pyilmbase-2.3.0.tar.gz 524975 BLAKE2B 7c3114921392ad29198025c672c366e6c98d2da968ed213ccfb446533b81fae4b78c687aba2108e476e16c4e97f11924799d0b0474ff3f82f17632f886bb6a39 SHA512 c20c26155315f2ae38efc183e5f33e2c18610365f5f1bca7a50363a005ff91c8782177293290ea037cf5f164f9b404f5710ce3cccba862e5e7f830727753589f
EBUILD pyilmbase-2.2.0.ebuild 1129 BLAKE2B b3876947d8104e5dca92dc6e02780228b30c5c3b3fcf0975b8a8876b3b48e8f95990d16b1a94101626d439972128e0c4f0d901d847a93468f88592e92f0855bc SHA512 abe726f6a70ee90242eee1a9b70ca8386e09a1c7de32e30372407cf4c49ef653e260f392b15407f7d13d76b737a424699d72d0c35f92793c470bddeedbda3e65
-EBUILD pyilmbase-2.3.0.ebuild 1248 BLAKE2B 41abe6232321ab9a84d0397cd771c9cebf0cfab053a2c1aaca1570f5e2a548b2b5baa616f1f64753442450f8e3742b4250f6ab1a63300350f41e58d81d64124b SHA512 25237d6858103cede2d287d546f119ae546422aac9209091d84f50d4f68ca05a262ca1b9064131e804266ea2843e8e088107e8e67d1b1a3ba11df435c47ad511
+EBUILD pyilmbase-2.3.0.ebuild 1429 BLAKE2B 7910bc31dc4dd04c83ba7a68a20d1f56f35a20a42ae66b85edb88273e861debb3e8889975adb1741e686b78624ab7c02d76c82406f61bb41d396541646d31050 SHA512 9f918d152a48e83c188670b7f88af0c4b3e5b76dad9989d3fb99e278e9ce03639c10c1cfc2786b7bb060e47fca59e47d9bf3aae5d3f061da1065d456c0700fee
MISC metadata.xml 537 BLAKE2B 88a1d7d89fac2094eefd766ad23b01c12cc49bff080e83f6ad63318294c97b18ecd83c6d908979ae8345a6601898b7a01295d9db886f0de500e460129d9c4a6a SHA512 c685de970979ac4ad5c3392a4b41b23bb523da5d003e3f6757a8d61fbdf0be1ea2bddc1a756176a9887101cc5bd6e19f5ac7e038e9dc9e5976c676a8817b9a87
diff --git a/dev-python/pyilmbase/pyilmbase-2.3.0.ebuild b/dev-python/pyilmbase/pyilmbase-2.3.0.ebuild
index fda4c62db801..f0a627779b31 100644
--- a/dev-python/pyilmbase/pyilmbase-2.3.0.ebuild
+++ b/dev-python/pyilmbase/pyilmbase-2.3.0.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -38,10 +38,17 @@ src_prepare() {
}
src_configure() {
+ local boostpython_ver="${EPYTHON:6}"
+ if has_version ">=dev-libs/boost-1.70.0"; then
+ boostpython_ver="${boostpython_ver/./}"
+ else
+ boostpython_ver="-${boostpython_ver}"
+ fi
+
local myeconfargs=(
--with-boost-include-dir="${EPREFIX}/usr/include/boost"
--with-boost-lib-dir="${EPREFIX}/usr/$(get_libdir)"
- --with-boost-python-libname="boost_python-${EPYTHON:6}"
+ --with-boost-python-libname="boost_python${boostpython_ver}"
$(use_with numpy)
)