summaryrefslogtreecommitdiff
path: root/dev-python/pyhamcrest
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-07-14 21:03:06 +0100
commit8376ef56580626e9c0f796d5b85b53a0a1c7d5f5 (patch)
tree7681bbd4e8b05407772df40a4bf04cbbc8afc3fa /dev-python/pyhamcrest
parent30a9caf154332f12ca60756e1b75d2f0e3e1822d (diff)
gentoo resync : 14.07.2018
Diffstat (limited to 'dev-python/pyhamcrest')
-rw-r--r--dev-python/pyhamcrest/Manifest3
-rw-r--r--dev-python/pyhamcrest/metadata.xml8
-rw-r--r--dev-python/pyhamcrest/pyhamcrest-1.9.0.ebuild52
3 files changed, 63 insertions, 0 deletions
diff --git a/dev-python/pyhamcrest/Manifest b/dev-python/pyhamcrest/Manifest
new file mode 100644
index 000000000000..165c61418366
--- /dev/null
+++ b/dev-python/pyhamcrest/Manifest
@@ -0,0 +1,3 @@
+DIST PyHamcrest-1.9.0.tar.gz 376623 BLAKE2B 808c74aa4dff89467c126cbc0e18029a9504cb27bbf03662a90666f85c76d7d7617260f50d35acde3a8e9e437b846589423cbb3697f8ceb86d0b5b838c586ebd SHA512 3b8393d0079b619b208ec7f06ed5133c4ff9d9dba050f818adf56347fc2225fd1c85d60f3dc262b7b9722061f0b8e4966180b6b96245a371e578d0d51633b4b0
+EBUILD pyhamcrest-1.9.0.ebuild 1227 BLAKE2B 173ad0e42c44e083043203c40435865697bf5222e7bd4fe907db296fbea627aa06de8a99dd8842f259073ecedbd902a4bc7c9eaf7b74540e1afe53d85832612d SHA512 4bca028ef12f224a122978f6ca9ed259306b7817f5f6182cd462d366b944458bf2657ff7a25f2993582d69cd9e5780004b65702062c2f6cbe429f6c39eefb81d
+MISC metadata.xml 271 BLAKE2B c9035b9fb7a0fca1355aeda317feceecac5790bb6723360063b236d6633a040a594eea8f304c3b5bc8e918b1781f0e5e887ec15225d51a021592391195b7e8ff SHA512 89f447b79dadbb441c4c51527f486fcf7110b67c0a86c9fe6413c563463be57089faa1ddb36701080c368ff0a8442532bc774602e0120cd5466a4d7fb6bb6e0d
diff --git a/dev-python/pyhamcrest/metadata.xml b/dev-python/pyhamcrest/metadata.xml
new file mode 100644
index 000000000000..6d5ace80933c
--- /dev/null
+++ b/dev-python/pyhamcrest/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <upstream>
+ <remote-id type="pypi">PyHamcrest</remote-id>
+ <remote-id type="github">hamcrest/PyHamcrest</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/dev-python/pyhamcrest/pyhamcrest-1.9.0.ebuild b/dev-python/pyhamcrest/pyhamcrest-1.9.0.ebuild
new file mode 100644
index 000000000000..596f8cb84574
--- /dev/null
+++ b/dev-python/pyhamcrest/pyhamcrest-1.9.0.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5,6} )
+
+inherit distutils-r1
+
+MY_PN="PyHamcrest"
+
+DESCRIPTION="Hamcrest framework for matcher objects"
+HOMEPAGE="https://github.com/hamcrest/PyHamcrest"
+SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_PN}-${PV}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64"
+IUSE="doc examples test"
+
+RDEPEND=">=dev-python/six-1.4[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? (
+ >=dev-python/sphinx-1.2.2[${PYTHON_USEDEP}]
+ dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]
+ )
+ test? (
+ >=dev-python/pytest-2.6[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ )"
+
+S="${WORKDIR}/${MY_PN}-${PV}"
+
+RESTRICT="test"
+# the pypi tarball is missing the tests
+# and the 1.9.0 tag is missing in GitHub
+
+python_compile_all() {
+ use doc && esetup.py build_sphinx
+}
+
+python_test() {
+ py.test -v || die "Tests failed under ${EPYTHON}"
+ "${PYTHON}" tests/object_import.py || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/_build/html/. )
+ use examples && dodoc -r examples
+
+ distutils-r1_python_install_all
+}