summaryrefslogtreecommitdiff
path: root/dev-python/pyhamcrest
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-12 03:41:30 +0100
commit623ee73d661e5ed8475cb264511f683407d87365 (patch)
tree993eb27c93ec7a2d2d19550300d888fc1fed9e69 /dev-python/pyhamcrest
parentceeeb463cc1eef97fd62eaee8bf2196ba04bc384 (diff)
gentoo Easter resync : 12.04.2020
Diffstat (limited to 'dev-python/pyhamcrest')
-rw-r--r--dev-python/pyhamcrest/Manifest2
-rw-r--r--dev-python/pyhamcrest/pyhamcrest-1.9.0-r1.ebuild24
2 files changed, 6 insertions, 20 deletions
diff --git a/dev-python/pyhamcrest/Manifest b/dev-python/pyhamcrest/Manifest
index d4c307d70a46..967ada19147d 100644
--- a/dev-python/pyhamcrest/Manifest
+++ b/dev-python/pyhamcrest/Manifest
@@ -1,3 +1,3 @@
DIST PyHamcrest-1.9.0.gh.tar.gz 57650 BLAKE2B c497688f03ec3b072d8ab076fc096a442d5cbbd94493eae57779879ccb6f281477aeeb7f7a67e539442010e60194f9f04a6deddd1d2267e9743742b45433f124 SHA512 3a878637ed5138365416c170871a63640f089047b723c7ec8db893dd716c0b1cdad16a98584700405693b954af7d4868a8543d1a3fc58ded22b493c8c61661b4
-EBUILD pyhamcrest-1.9.0-r1.ebuild 2088 BLAKE2B 8bb6398d81ad72909c3b559b495b85c6eec91f88afff03c6aba58e2d1fa632a03f61bc34d6343e84e753efb28193ef99a9265d81f070b74f442994d24cf723bc SHA512 09982e0cf39b12019fd5946a79a7e7215ce26d12a1da09871b85c8ffb744a1b1397c14f373bae7df2f367082b4d8223559f956952017ecb6b4f6ea094a93e79b
+EBUILD pyhamcrest-1.9.0-r1.ebuild 1757 BLAKE2B 85c817db418a46e9bccb80ebc7cc82aeaefe301cb7fdf9f4224fc22826e888a421de9aa50b7e931d53bff5643b5c5f8612a423c3f2be9a29bba137746691a920 SHA512 575eeab6956f7bdd4a9b1e4f9bb4aa7fe30c5b3fdcaeb1c3ee700b7cd0366e5ed3b73b6cb78186c55a8adc25bb2df277dec5988e49ac83cd8aec8e94f9f8d6d2
MISC metadata.xml 297 BLAKE2B 1d304f6e46130d706190ceaa75f188fba8b3934ebcb42b48d7209f9a9dc67e3561cc2a823b9a591cd58a945161c382698178979e4dacf776178367e43c5519a7 SHA512 999f2517a446b5911d475789246dcb70a08566fba9ecec5f2b69fa29180fdfbb17f4f24b4c87ef71c422814bf7502da2812e5c7938293e96affe721d92e428fd
diff --git a/dev-python/pyhamcrest/pyhamcrest-1.9.0-r1.ebuild b/dev-python/pyhamcrest/pyhamcrest-1.9.0-r1.ebuild
index 9030f0d5741b..af768d7f74ab 100644
--- a/dev-python/pyhamcrest/pyhamcrest-1.9.0-r1.ebuild
+++ b/dev-python/pyhamcrest/pyhamcrest-1.9.0-r1.ebuild
@@ -12,31 +12,24 @@ MY_PN="PyHamcrest"
DESCRIPTION="Hamcrest framework for matcher objects"
HOMEPAGE="https://github.com/hamcrest/PyHamcrest"
SRC_URI="https://github.com/hamcrest/PyHamcrest/archive/V${PV}.tar.gz -> ${MY_PN}-${PV}.gh.tar.gz"
+S="${WORKDIR}/${MY_PN}-${PV}"
LICENSE="BSD"
SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~mips ~sh sparc ~amd64-linux ~x86-linux"
-IUSE="doc examples test"
-REQUIRED_USE="doc? ( || ( $(python_gen_useflags -3) ) )"
+KEYWORDS="~alpha amd64 arm arm64 hppa ~mips ppc64 sparc x86 ~amd64-linux ~x86-linux"
+IUSE="examples test"
RESTRICT="!test? ( test )"
RDEPEND=">=dev-python/six-1.4[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
- doc? (
- $(python_gen_cond_dep '>=dev-python/sphinx-2[${PYTHON_USEDEP}]' -3)
- $(python_gen_cond_dep 'dev-python/sphinx_rtd_theme[${PYTHON_USEDEP}]' -3)
- )
test? (
>=dev-python/pytest-2.6[${PYTHON_USEDEP}]
dev-python/mock[${PYTHON_USEDEP}]
)"
-S="${WORKDIR}/${MY_PN}-${PV}"
-
-pkg_setup() {
- use doc && DISTUTILS_ALL_SUBPHASE_IMPLS=( -3 )
-}
+distutils_enable_sphinx doc \
+ dev-python/sphinx_rtd_theme
python_prepare_all() {
# enables coverage testing which we don't want
@@ -56,13 +49,6 @@ python_prepare_all() {
distutils-r1_python_prepare_all
}
-python_compile_all() {
- if use doc; then
- esetup.py build_sphinx
- HTML_DOCS=( "${BUILD_DIR}"/sphinx/html/. )
- fi
-}
-
python_test() {
py.test -vv || die "Tests failed under ${EPYTHON}"
"${EPYTHON}" tests/object_import.py || die "Tests failed under ${EPYTHON}"